Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
2002 Escalade, 71 Eldorado Convertible
Joined
·
59 Posts
Discussion Starter · #1 · (Edited)
I just rebuilt my entire engine,trans,carb,put in new water pump,new thermostat,new hoses, belts,Radiator Etc...I'm not getting pressure on my top hose, the engine has been over heating into my over flow, I have tried all that I know, it's not an over filling of fluid problem, I just brought back the new pump, my questions are what could it be? Could the heater core be plugged? There is a switch that keeps switching on and off while running hot, could there be a water control valve causing this? The car has starts and runs great, but isnt holding pressure. Any ideas or links to other threads? Thanks
 

·
Registered
2002 Escalade, 71 Eldorado Convertible
Joined
·
59 Posts
Discussion Starter · #2 ·
I have switched everything on here for a second time, and still no pressure on top hose, is this normal not to have a tight hose?
 

·
Registered
2002 Escalade, 71 Eldorado Convertible
Joined
·
59 Posts
Discussion Starter · #4 ·
I have a new radiator cap 16lb one, the car now build pressure, I didnt have the fan shrouds on there, when I drive it for awhile it still over flows, is this normal? Should I check my heater core? Thanks
 

·
Registered
Cadillac
Joined
·
58 Posts
How about the thermostat?

What do youi mean by no pressure on top hose?

The (complete) system should be pressure up with the outlet hose (top) having slighly more pressure becauase it';s the discharge and when cold should not flow. As the stat opens the top hose should get warm, and then hot.
 

·
Registered
1980 FBC
Joined
·
3,268 Posts
A lot of coolant pushig past a 16 lb cap is not normal. Are you feeling a large volume of HOT air across the radiator with the engine hot? Worn out fan clutch or crap in the radiator will inhibit heat exchange. Fan shroud isn't an option. It needs to be there. How does the car run? Is the timing retarded? These engines are thinwall modern castings and run quit cool when everything is working OK.
 

·
Registered
2002 Escalade, 71 Eldorado Convertible
Joined
·
59 Posts
Discussion Starter · #7 ·
The car runs good, it seems to be hot, what is the timing on a 425 the book I have is for a 500 ci, It seems to be retarded a bit, it was 90 degrees yesterday and after running for a couple of hours the idle dropped. There wasnt much that ran into my overflow, but there was some. My radiator is brand new. Thanks
 
G

·
All the key points have been mentioned in this post. I would recommend using a cooling system pressure tester on the system. Just be cautious of a leak into a cylinder. You can rent for free at Autozone.
 

·
Registered
2002 Escalade, 71 Eldorado Convertible
Joined
·
59 Posts
Discussion Starter · #9 ·
All the key points have been mentioned in this post. I would recommend using a cooling system pressure tester on the system. Just be cautious of a leak into a cylinder. You can rent for free at Autozone.
Could it be the timing is a bit retarded? There is a slow drip into my overflow, I can hear it bubbling in my top hose. How would I notice a leak into my cylinder, wouldnt there be white smoke out the exhaust? Thanks
 

·
Registered
2002 Escalade, 71 Eldorado Convertible
Joined
·
59 Posts
Discussion Starter · #10 ·
I just wanted to thank all of you for the suggestions. I figured it all out. It was a simple fix or should I say a mistake. I cleaned out the resivoir when I rebuilt everything, and I forgot to put the hose that goes on the inside of it. Thanks again
 
1 - 10 of 10 Posts
Top