Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
2007 Escalade ESV
Joined
·
364 Posts
Discussion Starter #1
Well, just as I had the wife's buggy running in tip top shape, the Low Oil Pressure warning banner and the incessant warning chime has shown up outta no where. I've tried to get myself educated on the topic and as usual the road starts to fork immediately. Oil pressure sensor, Oil pump, Cam bearings and so on. The truck has 125K on it and is running great after cleaning the Throttle body. Then this malady shows up. I would like to hear where to start this goose chase in the most likely manner. Sue would be helpful if these trucks had an oil pressure gauge to give us a jump start. Frustrated again............!!!!!!!!!!!!
 

·
Registered
08 Escalade ESV awd, 05 Yukon Xl Denali awd, 06 SRX sold
Joined
·
1,852 Posts
Easiest and least expensive would be just to replace the sensor, in my opinion
 

·
Registered
2009 AWD Escalade Ultra Luxury Raven Black
Joined
·
1,800 Posts
That would be the easiest and cheapest, prior to checking your oil pressure with a mechanical guage.
 

·
Registered
2007 Escalade ESV
Joined
·
364 Posts
Discussion Starter #4
problem solved

So it turns out that the sensor was bad........bought the sensor from O'Reilly autoparts and had my neighbor install it. I would have done it but I just had surgery on my right wrist and couldn't reach back into the area to access it. He works for a local general all makes repair shop and he has a special tool from Snap On for this particular job. It had to be done because the audible chime was incessant. Paid him a 100 bucks to do the job on Valentines Day. That allowed him to take the Mrs. out for a nice dinner and kept me from getting "Country Raped" at the dealership.
 

·
Registered
2010 Premium w/ ALL options + 2004 Pontiac GTO LS6 "Beast"
Joined
·
1,196 Posts
Wow excellent story here. Most folks don't get that lucky with it being the sensor, or the inexpensive fix.
Curious what the tool is, could you maybe post a picture of it, or a part number at least?
 

·
Registered
2018 XT5 Platinum, 2014 S550
Joined
·
1,653 Posts
If you did not go to the switch immediately, I would have said replace Oil Filter first. Possibly Damaged / Blocked / Collapsed / Defective...
 
1 - 7 of 7 Posts
Top