Cadillac Owners Forum banner

1 - 10 of 10 Posts

·
Registered
Cadillac 02 STS
Joined
·
39 Posts
Discussion Starter #1
Ok...............I have an STS 2002...........I love my car but it seems like I am constantly putting oil in it. No oil in the driveway tells me not leaking, and as much as I can see, no oil around the engine. I have to put in appx 2 qts every month. I'm using 5w30 full synthetic, car has 75,000 miles. Is there something I need to look for/at? It just seems like it's an awful lot of oil to be putting in the car.

The manual says Change engine oil and filter as indicated by the GM Oil Life System (or every 12 months, whichever occurs first). Reset the system.

Well I change it every 3-5,000 miles because that's what everybody screams at me to do.
 

·
Registered
2013 XTS
Joined
·
2,087 Posts
Sounds like a normal Northstar to me. You may have seepage at the half case though. The rings are known to also let oil buy thus burning it off. How many miles are on the car ?
 

·
Registered
Cadillac
Joined
·
24 Posts
well i have a 97 deville that recently started leaking but i cant tell if its oil or dirty dex cool and my car is getting temps of 215-222 degrees any word on that....... & yes they eat oil and mine only looses about a about a quart a month so im confused and also when the temps are that high and i idle the oil light flashes. im up the river on this one
 

·
Registered
Cadillac 02 STS
Joined
·
39 Posts
Discussion Starter #5
Sounds like a normal Northstar to me. You may have seepage at the half case though. The rings are known to also let oil buy thus burning it off. How many miles are on the car ?
75,000 but after reading the archives as suggested I am under the impression it's normal.
 

·
Registered
Cadillac 02 STS
Joined
·
39 Posts
Discussion Starter #6
Yes. Look at the Technical Archives at the top left of this page.
Thanks, I did a search on the subject but didn't look in the archives......actually never realized they existed. Thanks for pointing it out, any further questions i will definitely look there first! Although those colors give me an awful headache................seriously i have to copy and paste into word in order to read it comfortably.
 

·
Registered
02 STS
Joined
·
1,262 Posts
We haven't had an oil debate for over 6 months now :lol:
1) Read the tech tips
2) Change your oil as per the oil life monitor... ignore the people yelling at you... they are dead wrong
3) There is some anecdotal information that conventional oil may actually work better in our North*s.. You can run synthetics if you wish but you are not accomplishing anything. Synthetics tend to be "thinner" then conventional oils... more of it can (and probably will) "leak" past the valve guides and rings and burn up...
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
71,110 Posts
I use Pennzoil 5W-30 Platinum synthetic in my STS and use a quart every 3,500-4,000 miles. WIX 51522 filter. Nobody asked how full you are trying to keep your oil up to......most N*'s will quickly burn off the first half quart of oil if filled to the top of the hashmark on the dipstick. The trick is to run the level at halfway, or a bit more, down the hashmark from "full". Also several replies speak of leaks when you say you have none..........and you're wasting money on oil/filters with a 3,000 mile interval. Nowadays, with moderate city/highway driving, 5,000 - 7,500 is good, and with all highway, you can go past 10,000. 75,000 miles is "low mileage" for a N* engine. You're due for a coolant change.
 

·
Super Moderator
2010 DTS
Joined
·
87,575 Posts
well i have a 97 deville that recently started leaking but i cant tell if its oil or dirty dex cool and my car is getting temps of 215-222 degrees any word on that....... & yes they eat oil and mine only looses about a about a quart a month so im confused and also when the temps are that high and i idle the oil light flashes. im up the river on this one
Those temps are normal. The oil light is probably a bad pressure switch. Replace it.
 
1 - 10 of 10 Posts
Top