Cadillac Owners Forum banner

1 - 12 of 12 Posts

·
Registered
93 SedanDeville
Joined
·
78 Posts
Discussion Starter #1
Ok i really need some help here. I have a 93 sedandeville 4.9 engine self leveling supsension. I am having very strange problems. !st my interior lights on the back of the back doors stay on with the doors shut but the rest go off. If i open the doors those 2 go out and the rest come on like they should.

2nd just happened today i have no turn signlas yet the fuse is ok might this be the flasher? Where is the flasher located?

3rd My door locks dont work and the fuse is fine(auto door locks btw) might just one switch have gone bad and interrupt the whole circuit or am i missing a fuse?

If there are relays for these id love to know other than that the cadi is fine!
 

·
Registered
1998 Deville D'Elegance
Joined
·
133 Posts
Ok problem 1: Strange but check to see if they are turned on, on my 98 you can press them in to turn them on so they will work with the doors closed. Still on with them open thought that's what makes yours confusing.

2: Flasher is either in the fuse block or under that dash, I can't help any more than that right now, but if you or someone you know has a service manual (even a haynes or chilton) that will give you the location.

3: Check to see if all the fuses are in place, may be some under the dash and under the hood. Check your owners manual for location. To check the switch find the 2 wires that go to the switch that are closed (shorted) when the switch is pressed and short them manually for a second.
 

·
Registered
1998 Deville D'Elegance
Joined
·
133 Posts
Welcome to the confusing world called Cadillac. Never seen so many wires, switches, lights, sensors and relays on anything that didn't fly.
 

·
Registered
93 SedanDeville
Joined
·
78 Posts
Discussion Starter #4
Ok 98 let me clarify a bit on the rear passenger doors there are 2 lights on the backside of the armrest and 2 on the side of the back pillars. The 2 on the door come on if the doors are shut but go off when the door is opened. All other lights work fine. To keep from draining the battery i just remove the fuse(which isnt the door lock fuse).

The door lock problem i will look into when i get a warm day off as i think its just a switch. Im gonna chang flasher soon as i get off work today as the cadi is the wifes daily driver not mine =(
 

·
Registered
1926 Model T street rod, 2000 Jaguar XJ8, 1999 Corvette.
Joined
·
6,737 Posts
Check a blown BODY fuse. Also check all your cigarette lighter sockets for tin foil, dimes paper clips etc. If the body fuse blows, it will cause power door locks to quit, dome lites to stay on dimly and lighters to not work. The body fuse allows all these things to work with the key off. This is true on most 80's GM cars, hope its still correct on a 93?
 

·
Registered
Joined
·
52 Posts
There is an additional door lock fuse behind the lower sound insulator on the passenger side - in the relay center. Replace that and your door lock/courtesy light problem.

Regards,

Chris
 

·
Registered
Joined
·
31 Posts
How do you explain the digital dash dimming on and off at odd times? If I adjust my steering wheel and it locks into place real hard, the dash will come on, but dim out again after 5 minutes. Sometimes it comes back on when I start the car. But now it hasn't came back on in like a month. My fuses are located next to the brake pedal on the left side, they are all ok. I have taken off the front panel and pulled the digital dash out to check for loose wires, nothing. Right now I cannot tell how much gas I have, how many miles I have driven or how fast im going. Is there another fuse or possible short somewhere im not looking? I have asked this everywhere on this forum and no one has answered me. 1990 brougham 5.0 V8 RWD btw.
 

·
Registered
Joined
·
7 Posts
I posted this in the sticky thread above, but I'll paste it here too in case this thread has more traffic.


I have a 1993 Sedan Deville with a digital dash. Today for no apparent reason, when I started the car, the speedometer, radio, AC, fuel data, etc went blank. Then everything clicked back on. Then off again. This continued while various warning lights went on and off. I noticed that this happens even without starting the car. All I have to do is turn the electric on, and the whole dash goes haywire. Both the fuel and AC just have a "d" on the readout. Also, the defrost comes on full blast, and there's no way to turn it off. When everything finally goes back to normal, the AC reads 75 deg. This happened all 4 times I drove the car today. Each time, after about 15 minutes, it is okay again.

I'm not very smart when it comes to working on cars. And I don't have much $ for a couple more weeks. Is it safe to keep driving the way it is?
 

·
Registered
Joined
·
1 Posts
I also have a 1993 de Ville with electrical door lock problems and would like advice on how to fix it. Here is what happens: when the car is parked for a few hours all 4 of the locked door locks come unlocked - and the door locking actuator motors are running.
While driving, all 4 of the locked door locks unlock themselves and the door locking actuator motors start running.
Any ideas?

Weatherman
 
1 - 12 of 12 Posts
Top