Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Unicycle
Joined
·
11,009 Posts
Discussion Starter #1
I got the factory service manual, and found out all the cool and nifty things with the OBD (not all of it though, it is sooo cool) anyway, I reset the codes, now that the car has ran awhile and some miles on it, I have 2 problem codes, the first is:


(mine displays E and the code, but if I am reading it correctly, then P and E are the same thing)


P070 ....................................................... Intermittent TPS Signal

and

P098 ........................................... High RPM P/N to D/R Shift Under ISC


Can anyone help me with these? how would I fix it? do I need to replace the TPS? I do not hear/feel or sense anything wrong with the engine other then the rough idel the 4.9 is known for....... it dosn't seem like there is a high idel when shifting into gear either, any help? Thanks
 

·
Registered
Joined
·
1,805 Posts
P098 ........................................... High RPM P/N to D/R Shift Under ISC



I have the same code on my 92 Eldo it is going into the shop next week unless i can get some help soon. I know that it effects where your car idles and burns more gas than normal
 

·
Registered
Unicycle
Joined
·
11,009 Posts
Discussion Starter #3
Hmmmm, let me know what comes up about that....

anyone else have any info on these?
 

·
Registered
Joined
·
47 Posts
Night Wolf said:
I got the factory service manual, and found out all the cool and nifty things with the OBD (not all of it though, it is sooo cool) anyway, I reset the codes, now that the car has ran awhile and some miles on it, I have 2 problem codes, the first is:


(mine displays E and the code, but if I am reading it correctly, then P and E are the same thing)


P070 ....................................................... Intermittent TPS Signal

and

P098 ........................................... High RPM P/N to D/R Shift Under ISC


Can anyone help me with these? how would I fix it? do I need to replace the TPS? I do not hear/feel or sense anything wrong with the engine other then the rough idel the 4.9 is known for....... it dosn't seem like there is a high idel when shifting into gear either, any help? Thanks
If your not feeling a problem,I wouldnt worry about it. What it says is the car at one time lost the tps voltage signal more and that you shift out of park or nuetral when there were higher rpms than specs. If the check engine light is not on, then these are history codes, wait until they are current codes, then you can really diag. them. Right now it guess work
 
1 - 4 of 4 Posts
Top