Cadillac Owners Forum banner

1 - 2 of 2 Posts

·
Registered
None, Now an AUDI A4
Joined
·
555 Posts
Discussion Starter #1 (Edited)
my car had the rearend go out around 5k miles some sort of "seal issue" that the dealer said isn't uncommon on these cars.. well after there botched repair and 7-9 trips back to them to fix what was later found to be loose rear tierods it seemed ok. Welp about 2 months ago it started a noticable whirring noise at about 50 mph and the rear end worked itself loose to the point that shifting from park to drive would make a LOUD clunk. dealer in tampa (were i happend to be at the time) tighten rear down sent me on my way. had it done again about a month later and it has seemed fine. wel the whirring is getting louder and now i noticed while in the drive thru that when you accel in low speed situations there's a grinding noise. also kinda sounds like the rear may me SLIGHTLY loose and it's just kinda sliping around it's mounts.anyways i have a case with cadillac witch hasn't been bother in a while now. this is one of quite a few issues i have had wit this car but would like too keep it if possible. i guess my main questions ar....1.have any of you guys had an issue like this and did they EVER get it right? 2. what in the world could be causing that grinding noise?
 

·
Registered
None, Now an AUDI A4
Joined
·
555 Posts
Discussion Starter #2
Re: ok guys maybe you can help?

wasn't untill AFTER i posted that i noticed the sticky reguarding this issue...either way any imput on how long it takes them to fix it would be appriciated thanks in advance!
 
1 - 2 of 2 Posts
Top