Cadillac Owners Forum banner

1 - 19 of 19 Posts

·
Registered
03 Black Cts
Joined
·
9 Posts
Discussion Starter #1
i have a 03 cts, my cruise control hasnt been working since i bought the car in may and now the brake lights dont work! however the center one does work just the two side ones dont.

i know that it all revolves around the same switch but when i bypassed it there was still nothin... any ideas?
 

·
Registered
Joined
·
41,011 Posts
Just the obvious..have you checked the bulbs? :welcome5: to the forum!
 

·
Registered
03 Black Cts
Joined
·
9 Posts
Discussion Starter #3
thank you!!

of course... that was the first thing i checked they are good... and the sockets too
 

·
Registered
03 Black Cts
Joined
·
9 Posts
Discussion Starter #5
your funny....

already checked those too... got anything else?
im brighter than that
 

·
Premium Member
2006 STS V8 AWD, '95 Ford Ranger
Joined
·
28,974 Posts
What color is the dashboard? With pewter dash cars you can pull the trouble codes with the DIC. Also the brake light wiring and cruise controls are different. Give us some information to go on.
 

·
Registered
Black the Darkside
Joined
·
22,415 Posts
For both brake light go out at the same time is highly unusual for the filaments to burn. I think the CTS has two fuse locations. Under the rear seat and under the dash? I suspect fuses.

EWILL, you out there? :)
 

·
Registered
Joined
·
41,011 Posts
your funny....

already checked those too... got anything else?
im brighter than that
Nope. Sorry, that's all I've got. :lol: Just hang around here and maybe some big strong Caddy tech will show up to help. :RightTurn: Good luck!!

(If one doesn't show up, go to the lounge and start a thread called "paging EWill3rd".)
 

·
Registered
03 Black Cts
Joined
·
9 Posts
Discussion Starter #11
BOTH FUSES GOOD! :)
im not sure if the original dash was pewter or not... but i tried to get codes and nothing came :/

oh and AznPryde... thanks for the help
all the answers in one comment!
 

·
Registered
2005 CTS 3.6L, 2006 350Z, Ducati 996s
Joined
·
2,449 Posts
BOTH FUSES GOOD! :)
im not sure if the original dash was pewter or not... but i tried to get codes and nothing came :/

oh and AznPryde... thanks for the help
all the answers in one comment!
I help any way I can, even If Im only helping myself :)
How did you check the codes? You pressed F1 and F6 at the same time, held for about 3-5 seconds right? That should give you a list of all codes thrown.

Your dash is called pewter, but its not really that light colored. It's more like a charcoal, a very very dark grey. The newer years are a nice deep black.

When do the brakelights not work? Is it only when braking, or at all times, even during normal operation at night.

What about adjusting the autoheadlights? Tried this?
 

·
Registered
03 Black Cts
Joined
·
9 Posts
Discussion Starter #13
they never work, when lights on or off... auto or not... the top one is the only one that works...

thank you! im goin to try the codes again...

but aznpryde i have another question for you, why is my car so slow in 2nd gear? the acceleration is HORRIBLE, and i just had my filters changed, complete tune up.

its not the tranny either i just got it checked... wht you guys think?
 

·
Registered
03 Black Cts
Joined
·
9 Posts
Discussion Starter #15
oh bibird... yes im sure... i wasnt the only one who checked them either, if you have no faith in my judgment!! thank you
 

·
Registered
'11 CADILLAC CTS
Joined
·
356 Posts
I may be wrong but i'm pretty sure the wiring for the brake lights, cruise control and T/C are the same. When I had my issue with car not removing out of park, based on the codes it indicated both cruise control, T/C and the brake lights. The fuses kept blowing for the brake lights and turn out to be a short in the wiring system for the brake lights which also disabled my T/C and Cruise Control.
 

·
Cadillac Technician
none
Joined
·
11,051 Posts
Looking at the schematic I see it is very odd indeed that your regular stop lights do not work but the 3rd brake light does (CHMSL is what we call it, Center High Mount Stop Lamp)

There is a splice pack called SP 302 that feeds power to all three lights.
How do you know the bulbs are good? It can be hard to tell by looking at them, did you replace them and end up with the same result?
Do you have any tools like a test light perhaps? I might be able to guide you in some diagnosis if you are handy with things like that.

If the CHMSL works, that eliminates a lot of stuff, fuses, wiring, the stop lamp swith and maybe some other things.
The ECM monitors circuit 17, this is the brake lamp circuit. If the computer doesn't see the voltage drop accross the bulb filaments then the cruise won't work, period. When you fix the brake lamp problem you will fix your cruise control.

Has this car ever been wrecked?
Do the other lights work in the tail lamp assemblies? Like the park lights and turn signals?
You could have some grounding issues or there could be a problem with the splice.

The answers to those questions will dicatate my next response.
Thanks to my fan club for talking me up, ;) I hope I can help you as much as they brag that I can.
:D
 
X

·
Guest
Joined
·
0 Posts
"bi"bird? interesting assessment...

J/K I'm always looking for a funny. Welcome to the madness. Sorry I can't be of any help. Looks like everyone else has covered it. :thumbsup:
oh bibird... yes im sure... i wasnt the only one who checked them either, if you have no faith in my judgment!! thank you
 
1 - 19 of 19 Posts
Top