Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
2 years ago I had the engine in a 87 deville changed out. The engine was a remanufactured and it has done well for 50,000 miles. Driving down the road a couple of weeks ago hot light came on and I got it off the road and turned it off as quickly as possible... Managed to drive it back home (drove it til hot light came on, let it cool down, drove it again) and found coolant low.....I have found 1 cylinder not firing and I am defanitely losing coolant to the engine. (no leaks outside) warmer it gets, more it smokes....have tried to seal it with stopleak of various strengths... Nothing seems to be effecting the leak.... (the 2 year old heater core seems to be effected) have put to much money in this car to throw it away.... I am considering doing the next change myself... I am thinking the major problem at this point is a warped head.. Any thoughts from someone that knows these cars?????
 

·
Registered
Joined
·
305 Posts
djcalaska said:
2 years ago I had the engine in a 87 deville changed out. The engine was a remanufactured and it has done well for 50,000 miles. Driving down the road a couple of weeks ago hot light came on and I got it off the road and turned it off as quickly as possible... Managed to drive it back home (drove it til hot light came on, let it cool down, drove it again) and found coolant low.....I have found 1 cylinder not firing and I am defanitely losing coolant to the engine. (no leaks outside) warmer it gets, more it smokes....have tried to seal it with stopleak of various strengths... Nothing seems to be effecting the leak.... (the 2 year old heater core seems to be effected) have put to much money in this car to throw it away.... I am considering doing the next change myself... I am thinking the major problem at this point is a warped head.. Any thoughts from someone that knows these cars?????
Head gasket?
 

·
Registered
Joined
·
17 Posts
If you are losing coolant into the combustion chamber, I.E. Smoking, it is my experience that your head gasket is shot. You may be on the right track with warped heads. Unfortunately repeatedly driving it until the light came on and letting it cool down may have damaged the heads or head gasket. (How many miles?)

I would do a compression test on the cylinder you suspect is not firing. You may also want to do a pressure check on your coolant system. It sounds like a major failure and you may have already diagnosed it...

On a side note I would think the heater core is not function because it has no coolant being pumped through it.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #4
Thanks for the feedback.. I am not a mechanic so I need all the help I can get.. Unfortunately I drove the off and on for about 45 min... The gasket is most definately gone... It must be a bad leak.. Smokes like crazy and sucking down a lot of coolant... I have been rebuilding this car and I am not sure it is worth continueing.. Greatest riding car... at 230,000 I may to admit defeat if this is going to a 50,000 repeat....
 
1 - 4 of 4 Posts
Top