Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
escalade 04
Joined
·
38 Posts
Discussion Starter #1
Can someone give me some ideas on how to maybe get some cold air to come out? It blows out fine, just hot air. I put a tall can off freon in it from auto zone, but that didnt change anything. SOmeone told me that sometimes something on the compressor sticks and i need to pull it out or something, any ideas
 

·
Registered
Escalade
Joined
·
5 Posts
I have a similar problem, however only on the passenger side. I believe it to be the air diverter actuator. I'm not sure where it's located yet, but if the actuator doesn't open, then the fan simply blows the outside air. I've heard it suggested here to disconnect the battery for a minute, then hook it back up. Does anyone have any idea where the passenger/driver actuators are located?

You could also check to see if the rear A/C is working. That may determine if it's your compressor or just the actuators.
 

·
Registered
2003 Diamond White ESV
Joined
·
288 Posts
Can someone give me some ideas on how to maybe get some cold air to come out? It blows out fine, just hot air. I put a tall can off freon in it from auto zone, but that didnt change anything. SOmeone told me that sometimes something on the compressor sticks and i need to pull it out or something, any ideas
Is the compressor kicking on?
 

·
Registered
Cadillac Escalade EXT King of Mods
Joined
·
595 Posts
Mine did the same thing when it first got hot out. I thought it was a freon issue. After further inspection it was the belt from the compressor. I replaced it now it's cold as ice. The belt is located under the passenger side sort of under the coolant tank. U can see if from under the truck. It could also be the compressor itself.
 

·
Registered
1992 STS / 2005 MB G500 / 2003 STS / 2006 XLR-V
Joined
·
11,694 Posts
Mine did the same thing when it first got hot out. I thought it was a freon issue. After further inspection it was the belt from the compressor. I replaced it now it's cold as ice. The belt is located under the passenger side sort of under the coolant tank. U can see if from under the truck. It could also be the compressor itself.
I had a 2002 BMW X5 4.6iS that had the EXACT same problem, A/C accessory belt shredded to bits. A dead compressor on a 2004 truck would be pretty sad.
 

·
Registered
'02 Escalade
Joined
·
200 Posts
If your system got let up to atmosphere, you'll need to hook up a vacuum pump to suck all the air out of it before you refill with R-134a. I'm assuming that's the stuff you bought when you said freon. Since your truck was wrecked, its possible that you have a leak some where in the system so using some of the 134a that has neon dye in it is a good idea. If you see that stuff leaking out of any of the joints or the compressor, replace the necessary parts (o-rings might be bad/cracked), hook the vacuum pump back up to vacuum out the system and then refill with more R-134a. If the system knows its low on refrigerant or there is a problem, it will lock out the compressor so you'll need to trick it out or reset the computer to get the compressor running so you can load in the new 134a. On my STS, I'd get the Low Refrigerant message on the dash which would disable the compressor and trip a code which I could reset through the computer, but I'm not sure you can do that with the 'Lade. I haven't had any A/C issues yet. Pulling the battery cable might do the trick. Or you might have a bad belt or actuator.
 

·
Registered
Cadillac
Joined
·
123 Posts
Just started using A/C here last week...Started blowing warm air 3 days ago...Belt was dry rotted and broke...$50 for parts and labor..After I saw them do it, I could have it done it myself....BTW: The GM store had the Goodyear gatorback belt "top of line" for $13....Regular belt was $7
Murrays wanted $25 for the same gatorback belt..It will say Suburu on it. Ice cold now.
 

·
Registered
99 Escalade (sold) 03 Escalade EXT (sold) - 07 Escalade EXT
Joined
·
1,363 Posts
blaaaaaaaaaaaa this is the time of year everyone wishes they had a working a/c .... mines shot too .... make sure you guys turn the a/c on a couple times during the winter to gets the seals oiled... i bought my truck in october and it hasn't worked ... guess now is the time to get it checked out
 
1 - 8 of 8 Posts
Top