Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
cts
Joined
·
8 Posts
Hi wondering if anybody could help me I have a euro spec 2006 CTS 3.6 when switching on ignition there is no check engine light which I think should come on for a few seconds then go out I also scaned the car and there was a code p0451 which also should have put on check engine light I have pulled the instrument panel out but can't see how to change bulb also the manule says this could also be a fuse so I would like to know either how to change bulb or which fuse I need to be looking for many thanks neil

Hi, I'm wondering if anybody could help me. I have a euro spec 2006 CTS 3.6. When switching on the ignition there is no check engine light, which I think should come on for a few seconds then go out. I also scanned the car and there was a code p0451 which also should have put on the check engine light. I have pulled the instrument panel out but can't see how to change the bulb. Also the manual says this could be a fuse, so I would like to know either how to change bulb or which fuse I need to be looking for.

Many thanks,
Neil
 

·
Registered
cts
Joined
·
8 Posts
Discussion Starter #2
I figured out the bulbs are soldered in so I would like to check the fuse which ever it is any help would be much appreciated thanks
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,803 Posts
The bulbs are actually LED and they last for 15 years plus. So I highly doubt it's burnt. Besides I would think there are two of them that light up the CEL. You'll know more about how many than I would.

When I arrive home, I'll check my shop manual to see if there's a fuse and where.

KOT
 

·
Registered
cts
Joined
·
8 Posts
Discussion Starter #4
Thank for your help I only bought it 2 week ago for my wife and light has not worked since I bought it I think so after I find the fuse my next thought is its been tamperd with but that seem unlikely as the code was minor and I fixed it by putting some grease round the gas cap (parts are hard to find in the UK) and the screws at the back of the I.p don't look lie they have ever been touched
 

·
Registered
CTS 2007 Sport Luxury
Joined
·
145 Posts
I have had a look in the handbook, and cannot see a fuse marked for this.
All it says in the relevant section, is that it should illuminate with ignition is on but with the engine not running, if the light does not come on, have it repaired. ???
Pete (UK)
 
1 - 5 of 5 Posts
Top