Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
136 Posts
Discussion Starter #1
I replaced the Gold series head unit in my 92 eldo and the radio/cd/tape/fm works fine. But the sound just doesn't seem as full a sound as before....Is there a fuse on the main amp in the trunk...or is it a relay...HELP!
 

·
Registered
Joined
·
1,406 Posts
What sound is lacking? Bass or treble? Did you replace the head unit with the same model? I assume you went from Delco Bose Gold to Delco Bose Gold, not non Bose to Delco Bose Gold. You title says "No Boom" I assume you mean no Bass, but do you still have treble? Are all of the speakers working?
 

·
Registered
Joined
·
136 Posts
Discussion Starter #3
Yes I replaced it with a refurbuished unit(new cd pack) Gold original radio from AJR in Mlps,MN. Everything works fine it just seems the sound is not as rich both bass and treble. There are 3 fuses 2-10amps and one 30amp, the manual says the 30amp runs the bose amps....will the system still work if this 30 amp driving the amps is blown? Hate to waste time taking off the strut and fuse cover in the engine bay to get to the fuse block that has this 30amp just to find it's fine.... Maybe I'm not hearing right:hmm: and everything is fine but I swear it sounded richer than it is???
Thanks
Guy
 

·
Registered
Joined
·
1,406 Posts
No, the speakers will not work if the fuse is blown. It almost sounds like your rear speakers are not working. The rears are the ones that give the most bass, but the fronts do give off a considerable amount. So if the rears are not working, it would pretty much sound like your problem. This is probably a dumb question, but is the fader and the balance set right? According to my owners manual the Bose fuse is in the trunk. On the left side, there is a small panel with little mini fuses and the bose fuse is there. Try turning the radio on and listen in the back seat to see if your rear speakers are working.
 

·
Registered
Joined
·
136 Posts
Discussion Starter #5
Removed 10amp fuse, Unplugged CDM box in the trunk to get model number form the CDM...it has been re-worked once before in '97 turns out, there was a service sticker on it from a company in Mlps..no longer in bussiness. Well plugged everything back in.....Black Eyed Peas never sounded so good. IT WORKS AGAIN! Turns out early signs CDM is going to die....AJR can check and rebuild it for a 100.00. I'll be bring it in to AJR.
Hope this helps someone else.....stereo will still work but sounds like cheep ass Walmart radio....it's the CDM going....when your fm and antena stops working it's done.
Thanks
Guy
 

·
Registered
Joined
·
1,406 Posts
Thats great! I never knew that the box in the trunk did anything other than recieve the fm signals. "The Boogie that be" really sounds good on the Bose speakers.
 
1 - 6 of 6 Posts
Top