Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
136 Posts
Discussion Starter #1
Replaced my Gold Seires head unit on my 92 eldo. Everything on the radio works fine now, but the sound just does not seem as full a sound as it use to. Is there a fuse on the main amp in the trunk? Is it a relay? Help!
 

·
Registered
94 Eldorado, and a 99 ETC
Joined
·
3,887 Posts
I have heard that if you replace the stock head unit, you'll have to replace the stock speakers too, in order to see any improvement. The only head unit that works good with those speakers is the stock one.
 

·
Registered
Joined
·
136 Posts
Discussion Starter #3
I replaced it with the original refurbuished(updated cd player) head unit from AJR,Mlps.MN. I looked thru the fuse info....3 fuses, one 10amp 12v continuse for clock and settings, one 10amp 12v inginition runs radio, and a 30amp runs Bose amps. In a 92 Eldorado the 30 amp tucked under the fuse cover in the engine compartment it's the fuse block next to the fuses you can get to. You have to take the brase strut off and the cover to get to it. Does the stereo still work if this 30amp is burned out just not driving the amps? I did not have time to look at it yet....running around picking up a recuvred, restored '70 hemi cuda distributor for a buddy with MS. Tonite? if someone doesn't tell me here not to waste my time telling me the stereo will not work if the 30amp is blown....
Thanks
Guy
 

·
Registered
Joined
·
136 Posts
Discussion Starter #4
Just a heads up....it is early signs of CDM failing. Unplugged 10 amp radio fuse in the trunk, and everthing to cdm to get a model number....plugged everthing back in...Black eyed peas never sounded better! AJR in Mlps can check the CDM and rebuild it for a 100.00. Next step to have it bench tested...and re-built before it fails. Sooooooo. The Bose gold can still work but sound like a Walmart/bestbuy cheep ass stereo....it's your cdm...hope this helps others
Thanks
Guy
 
1 - 4 of 4 Posts
Top