Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
96 STS
Joined
·
98 Posts
Discussion Starter #1
I made a forum a while ago about my 96 STS battery dieing after sitting for a couple days. I bought the car from a Ford Dealership (that was my first mistake right there) and who ever owned it before put in a in-dash tv/dvd player and alpine front/ rear door speakers. I sent my car back to the dealership 3 weeks ago for them to find out what is wrong with the car and why the battery is draining..........
Ford sent my car to a Caddi dealership (and yes its still there) and they found out that it is the aftermarket audio that is causing the battery drainage. They said since whoever put in the aftermarket audio took out the factory BOSE Amplifier which is tricking the ECU causeing the current draw.

WTF!!!!!!!!!!!:want: So they had to take out my tv/dvd player and put in the factory BOSE cd player and kept the apline speakers but hooked them up to BOSE Amplifier.
So your saying we cant have any aftermarket audio in our cars without having a current draw, thats B/S!!! Or is the dealership lieing to me and just lazy to reinstall the aftermarket audio. Has anyone else added aftermarket audio to thier cars and had any problems. The only good thing is that i dont have to may i dime Ford is, but thats beside the point.

SOMEONE PLEASE HELP ME OUT!!!!:banghead:
 

·
Banned
2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
Joined
·
15,987 Posts
Ok i dont know why its doing this to your car however i do know something you can do to fix it. Install a kill switch in the car. Find the power wire (red) thats on the new HU. Rig it to a switch then connect it to the plug. When you turn the car off turn the switch off and it will kill power to the radio. GL
 

·
Registered
96 STS
Joined
·
98 Posts
Discussion Starter #4
I finally got my car back. They Cadillac brought the car to a car audio shop and they put in a pioneer cd player deh-1700 and they said they but in a cadillac interface cable yea sh*tty cd player but it works and no problems have accured now. And they didnt put in the Bose amp either. I wonder how they did it! I noticed that my speakers arent hitting bass notes as much as my other headunit which was a tv/dvd/cd player. Im just happy to get it back. Thanks u guys for all the help
 

·
Registered
1989 Sedan DeVille is now just a fond memory ....
Joined
·
10,429 Posts
I'm going to move this to the audio section, let's see if we can get some more ideas on it there.
 

·
Registered
1998 deville, 2000 sls, 2006 CTS-V, 2001 STS, 2007 STS V8
Joined
·
440 Posts
hmm, that doesnt make any sense..in my 94 sls I had pioneer speakers all around with an infiniti amp and sub..with the pioneer flip up dvd/cd player in the front, no problems at all. if you say its making your battery drain, I would think that the alternator isnt giving enough charge to the battery when running. so, in that case, get a better alternator if you want that dvd unit. now in my 00 sls i have three tvs, two subs, two amps, a radar detector, all one one battery, with no problems.
 

·
Registered
Joined
·
1,406 Posts
This has already been discussed in another thread. The 96 and up sevilles have a different amp in them than the 92-95 seville. You have to get the interface cable.
 
1 - 8 of 8 Posts
Top