Cadillac Owners Forum banner

1 - 20 of 30 Posts

·
Registered
97 Deville Fwd
Joined
·
18 Posts
Discussion Starter #1
Hi guys I am Sam. I recently inherited a 97 deville from my father which is great however it has a few problems i was hoping to get some help on.

I own a 2004 gto lightly modified btw.. anyway, so i pulled a few codes out and i can obviously tell i need to change spark plugs because of the misfire codes..

i wanted to get some help on the rear suspension.. it has sagged all the way down. my father said he had the bags checked and they were fine. this was a while back though..

I just want to know where the first/best place to look is so that i can begin to find out what exactly went wrong back there. i tried lurking around to find a thread with similar issues but no luck... im sure one exists, i just didnt see it..

can someone please point me in the right direction
 

·
Registered
97 Deville Fwd
Joined
·
18 Posts
Discussion Starter #2
also.. i got a bunch of low voltage codes.. was this because the car was off and the alternator wasnt turning?
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
70,711 Posts
Low voltage - car OFF - entirely possible, especially with a weak battery.

Go down to Discussions, Item Specific: Cadillac Tech Tips. 9 pages of vital info and fixes. Look for threads on "electronic level control" or "level control compressor".

The unit is up in the RR inner fenderwell area. If you do not hear it run for 2 seconds about 8 seconds after Key:ON, there's something wrong. Most often the compressor locks up due to moisture corrosion - there's a filter/dryer on the compressor and over time it becomes saturated with the condensation from compressor operation. It then ruins the control head and maybe the compressor itself. The fuse is in the under seat fuse box (Rear seat - Deville ???)

Amazon or Suncore sites.
 

·
Registered
97 Deville Fwd
Joined
·
18 Posts
Discussion Starter #4
awesome... that is very helpful... that may very well be the case as i do not hear the compressor running... also i think the shocks are gone considering the rubber on the bags looks dry rotted.

under the rear seat? there is another fuse box? is there a relay too?

sorry for all the dumb questions, i know nothing of luxury cars much less air ride... im a performance kinda guy. i know about drag bags and things like that lol. which brings me to my next question.

would drag bags help me from bottoming out meanwhile i find the problem in the car? reason i ask is because i want go more aggressive on my gto.. havent decided full on drift car or full on track car.. but it will be a beast and i need a daily while its at the shop and i probably wont have it on the street much.

i pulled many codes... i will post them after work.. i was just surprised at how many there were. i just want to have this car running as good as possible.. i am on a budget considering my other project but i wanna get things as good as i can
 

·
Super Moderator
2010 DTS
Joined
·
87,430 Posts
Be advised that low voltage can set false codes. If the battery is holding a charge, I'd clear the codes and start from scratch.
 

·
Registered
1991 Cadillac Brougham D'Elegance 5.7 Litre, 1994 DeVille
Joined
·
6,796 Posts
Low back end means you have 2 problems- bad springs and something wrong with the leveling system. After you turn the key on you should usually hear the fuel pump running for a few seconds almost immediately and then a bit after that another noise from the back which is the compressor for the suspension.
 

·
Registered
97 Deville Fwd
Joined
·
18 Posts
Discussion Starter #7
yea. so i replaced the spark plugs and the check engine light turned off and i no longer hear misfiring from the exhaust..i need new coilpacks and wires as i saw some rust on the contacts....i replaced with ac delco.. platinum.. i was told not to gap them. is this true?

my compressor doesnt even power on and the rear shocks look dry rotted... i could not find that fuse panel in the rear seat..
can someone point me in the right direction as per finding the fuses and relays associated to the air ride leveler.
 

·
Registered
Joined
·
13,969 Posts
The acdelco plugs come pre-gapped... it's always a good idea to double check them to make sure they're still gapped correctly though

stick with the OEM ignition components for sure on this car or you'll probably have problems

i'm not sure about the arnott parts since i only sell the oem stuff... PM me your vin (once you get past 10 posts - only one more to go!) and i'll quote you on the GM parts
 

·
Registered
97 Deville Fwd
Joined
·
18 Posts
Discussion Starter #10
Sweet. Thanks alot. I will do.
Is there some sort of Teardown manual I can buy or view?
 

·
Registered
Joined
·
13,969 Posts
the best manual (imho) is the factory manual
buy it new from http://helminc.com (sometimes you can find them on ebay new but most ebay manuals will be used - but cheaper too!)
either that or the online manuals from AllData (alldatadiy) and Mitchell's (OnDemand) - those will also have the bulletins and other info but over time will cost you more since they're subscription based
 

·
Registered
97 Deville Fwd
Joined
·
18 Posts
Discussion Starter #13
dam now i dont know what to do.. my mother now gave me her 94 lincoln.. air ride works... im gonna give this a tune up and see how it runs...

lincoln 78k caddy 100k.

plus the town car should be cheaper to maintain. im gonna work on a list and fix the car with the cheaper invoice.
 

·
Registered
97 Deville Fwd
Joined
·
18 Posts
Discussion Starter #14
the a/c on the caddy cools great but doesnt like to blow out the proper vents.. it likes blowing it through the defroster.. sometimes it switches back to the way it should be.....

where do i need to look?
 

·
Super Moderator
2010 DTS
Joined
·
87,430 Posts
Defrost is the default mode. You have a vacuum leak. If the parking brake does not release when you put the car in gear, the release diaphragm would be the first thing to check, but first be sure you have vacuum at the supply line going into the cabin on the passengers side firewall.
 

·
Registered
97 Deville Fwd
Joined
·
18 Posts
Discussion Starter #16
i noticed that once the car is blowing through the correct vent, if you turn off the engine then on, it will continue to work properly.

but if i am to use the off button to manualy off the system, then i have to wait for it to want to blow out of the correct vent


where can i find said diagram? passenger side firewall?
 

·
Super Moderator
2010 DTS
Joined
·
87,430 Posts
i noticed that once the car is blowing through the correct vent, if you turn off the engine then on, it will continue to work properly.

but if i am to use the off button to manualy off the system, then i have to wait for it to want to blow out of the correct vent


where can i find said diagram? passenger side firewall?
What diagram?
 

·
Registered
97 Deville Fwd
Joined
·
18 Posts
Discussion Starter #18
sorry. fat fingers and smart phones dont always create the words i try to type..

i meant diaphragm. the auto correct must have changed it.

you are right about the parking brake.. i had to manually release it..

where do i start looking? can i get a picture if possible?
 

·
Super Moderator
2010 DTS
Joined
·
87,430 Posts
The vacuum diaphragm is on the parking brake mechanism. It's the only thing there with a vacuum line to it.
 

·
Registered
Joined
·
13,969 Posts
here's one for you ranger...

my parking brake releases perfectly when it's hot out... the colder it gets the less the parking brake pedal wants to release

it's always releasing but just not always coming up fully

i've got into the habit of pulling it up with my left foot toes

is this the same issue? a diaphragm going bad/leaking?
 
1 - 20 of 30 Posts
Top