Cadillac Owners Forum banner

1 - 10 of 10 Posts

·
Registered
2003 CTS
Joined
·
5 Posts
2003 Tachometer issue

I had my 03 CTS in for an A/C compressor and the shop gave it back with my Tachometer not functioning. Any ideas? I fought with the shop and they will not do anything for me.

I had work done at a shop specifically my a/c compressor replaced and they gave it back with my Tachometer not functioning. I have gone round and round with them and they will not do anything.
Any ideas?
 

·
Registered
98 DeVille, 97 DeVille d'Elegance
Joined
·
7,345 Posts
Not really the right forum for this. Post up in model specific forum and will get more looks.
The tach signal comes from ICM IIRC. What work did they do?
Sounds like a wire off between engine electronics and inside.
 

·
Registered
2003 CTS
Joined
·
5 Posts
Discussion Starter #3
They replaced my A/C compressor. I looked for a broken or disconnected wire but no luck.
Sorry for posting here I just downloaded the application. I will look for the CTS page.
 

·
Registered
98 DeVille, 97 DeVille d'Elegance
Joined
·
7,345 Posts
A wiring diagram will probably be necessary to track down the tach wire.
Could just be a connection was knocked loose.
 

·
Registered
2003 CTS
Joined
·
5 Posts
Discussion Starter #6
I started a thread and when I attempt to look at the comments I get an error.
I am looking for tachometer help on a 2003 CTS.
I gave it to a shop for A/C work and they returned it with my Tachometer not functioning.
 

·
Registered
98 DeVille, 97 DeVille d'Elegance
Joined
·
7,345 Posts
Your electrical forum thread was moved to vwhicle specific forum it seems. Occasionally posts show up wonky depending on how you are viewing the forums. Try web browser non mobile.
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,531 Posts
Re: 2003 Tachometer issue

Identical threads from incorrect forums merged into FirstGen CTS. 4-day redirects in place.
 
1 - 10 of 10 Posts
Top