Cadillac Owners Forum banner

1 - 20 of 21 Posts

·
Registered
CTS
Joined
·
23 Posts
Discussion Starter #1
Hey all I am new to this Forum and just bought a 03 CTS a month ago. After about 1K the fuel gauge started not working. Now the gauge isnt working, the TC light and security light is on, and the cruise control light will not come on. Every now and then the gauge will work and all of the lights will go off. Any ideas?? I hope I didnt buy a lemon
 

·
Registered
2003 CTS "Ebony Maria" 2005 Cadillac STS "Grace"
Joined
·
6,414 Posts
have you had the VIN ran yet? if not, go into the V forum and they have a sticky and post in there and somebody will run it for you...

welcome to the forum...
 

·
Registered
CTS
Joined
·
23 Posts
Discussion Starter #3
I just did the F1-F6 thing and it came back with 13 codes!!!??? Is this normal? they all have the asteric by them.
 

·
Registered
06 CTS-V
Joined
·
2,497 Posts
those arent the codes, those are modules that have codes. the ones with the asterics means there are thrown codes there. push the tune/select button to access the codes.
 

·
Super Moderator
2018 GMC Sierra, 1995 Jeep Wrangler
Joined
·
12,114 Posts
.....I hope I didnt buy a lemon
I hope so too. That's why it's best to protect yourself before you buy.

:welcome5: to the forums. I hope this place can be a good source of info and a great deal of help to you. :)
 

·
Registered
CTS 03
Joined
·
1,765 Posts
Hey all I am new to this Forum and just bought a 03 CTS a month ago. After about 1K the fuel gauge started not working. Now the gauge isnt working, the TC light and security light is on, and the cruise control light will not come on. Every now and then the gauge will work and all of the lights will go off. Any ideas?? I hope I didnt buy a lemon
If the cruise works, but the light won't come on, maybe it's the instrument cluster. You can find repacements on e-bay. There is a connector behind the cluster that may not be seated properly.
 

·
Registered
CTS
Joined
·
23 Posts
Discussion Starter #7
I have been thinkin maybe it was the custer myself. Every now and then the fuel gauge will work, when it does the the cruise control light works. If the cluster was going bad would it be throwing a bunch of codes? The engine light is not on by the way. Does the cluster go out alot? Thanks
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,820 Posts
Just check out the connection for the cluster. It's very easy to get to.

Take off the two pieces of plastic off of the steering column. They pop off with little force. Then there are two bolts in the lower two corners. I believe they are 8 or 10 mm. Once they are out, do yourself a favor and put down a dish towel or something on the steering column, this will prevent the face getting scratched up.

Then pry the top part out. This is where it's hard to remove. It's all by force though, there are no bolts on the top part. I believe there are 4 or 5 pressure points up there.

Once you have out, you'll see the connecton and how it's held on.

KOT
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,820 Posts
Yes,

Check this eBay auction. You can see the front and back of the cluster and how easy it would be. On the rear view, you can see where the pressure things I was talking about are. I was wrong though, there are only three of them. But you can see where they are at as well as the connection.

KOT
 

·
Registered
CTS 03
Joined
·
1,765 Posts
Yes, 03 -07 will work on your car, in addition, you will get an engine temp gauge in place of the analog clock. The wiring is already there for the temp gauge and it should work perfect. The only complicaion is the mileage. You can send them both to a company in Mich. (Specmo) and they will convert the miles for you, otherwise, the cluster will show the miles that were on replacement. You can leave it like that but when you sell the car you have to indicate on the title that miles are not acurate.

The new clusters are much nicer and brighter.
 

·
Registered
CTS
Joined
·
23 Posts
Discussion Starter #13
Well I removed the cluster this morning (after a bloody finger and broken clip) and un plugged it. I then re-installed it. The fuel gauge still isnt working and the TC light and security light are still on. Looks like I am going to replace the cluster. What year did the newer cluster come out??
 

·
Registered
The Mighty Kael, 2004 Black CTS, Every Option
Joined
·
2,432 Posts
this may not be the cluster at all.
if the tc light is on, and the security system light is on and the gauges do not work you may fried one of your computers.

on the 3.6L engine its a small 4 inch square metal computer with two large plugs going in and out.

you can sometimes find replacements on ebay. I do not know if this is the same case for the 3.2L

if the speedo and tach are working but not the gas gauge I would try with the computer first.
 

·
Registered
CTS 03
Joined
·
1,765 Posts
It's on the right side of the engine and it's called the ECM. You'll see two large connectors input and output to it. I don't know thw cost but you might find it on ebay.
 

·
Registered
CTS
Joined
·
23 Posts
Discussion Starter #19
Well I took the car to a shop and they said it was the ECM. Also the AC started turning on periodically, I had them look at it and they said the entire heater/ac control module had to be changed. Anybody know where I can buy these two parts for cheap? All I can sau is I hate caddy now:mad:
 
1 - 20 of 21 Posts
Top