Cadillac Owners Forum banner
1 - 16 of 16 Posts

· Registered
2011 Cadillac CTS Coupe Premium 3.6L DI
Joined
·
8 Posts
Discussion Starter · #1 ·
Hello all! I have a 2011 Cadillac CTS Coupe Premium with 180k miles on it. Maintenence has always been kept up on it, and my old MAF started to fail with intermittent "Service Traction Control" messages before throwing a CEL "P0100-00". Mind you, throughout all of this my car never misfired on a cold start. Ever. Even with the failing MAF.

I tried resetting it multiple ways by disconnecting the battery for 10 mins, and even starting the engine cold with it unplugged and letting it idle before plugging it back in and clearing the codes. When I started the engine cold with the MAF unplugged, it didn't misfire at all.

I went ahead and bought a Carquest MAF and installed it, cleared the codes from the ECU, and started the car cold. Misfired a couple of times (triggering a code but no CEL) before going back to normal. No more misfires for the entire drive and subsequent engine starts.

I'm thinking I may have a faulty MAF (even though it's brand new) and I don't want to damage the engine with it misfiring every cold start. Is there a proper reset process I'm forgetting?
 

· Registered
2011 CTS coupe 1989 Allante
Joined
·
5,931 Posts
Any car over 10 yesrs old that lacks a service contract, needs two things: a service manual and a quality scanner. Any inexpensive scanner that gives a code with many zeros (generic codes) is not scanning the actual module that is having a problem.
Least expensive decent one is Torque Pro which runs on an Android device (phone, tab) and uses an inexpensive dongle to communicate. It can display many parameters in real time and log them for review.
Even if you can't use, the local 15 year old gearhead will appreciate having the information available.
 

· Administrator
2002 F55 STS, 2014 Explorer XLT, F-150
Joined
·
79,975 Posts
The MAF has nothing to do with TC. Unless there's a wheelspin mismatch associated with the MAF ?????

MAF is Mass Air Flow - intake charge fuel mixture control.
 

· Premium Member
2023 CT5-V RWD / 2020 XT6 Sport / 2024 Lyriq AWD (reserved)
Joined
·
5,531 Posts
OP: If you have codes, run a mode 6. It will tell you which cylinders are misfiring and by how much. That can help you/us diagnose the issue at hand. I've heard of failing MAFs giving wrong info to the PCM which in turn causes misfires but I've not heard of that happening in our powerplants.


The MAF has nothing to do with TC. Unless there's a wheelspin mismatch associated with the MAF ?????

MAF is Mass Air Flow - intake charge fuel mixture control.
I suspect a typo in the first post...
 

· Registered
2011 Cadillac CTS Coupe Premium 3.6L DI
Joined
·
8 Posts
Discussion Starter · #6 ·
The MAF has nothing to do with TC. Unless there's a wheelspin mismatch associated with the MAF ?????

MAF is Mass Air Flow - intake charge fuel mixture control.
In my case, whenever I unplug the MAF it comes up with the service traction control message. It's weird. When my Bosch MAF failed, it came up with the "Service Traction Control" message, then a CEL afterwards. Got the new MAF, installed it, and the message went away (and the CEL after clearing everything).

I also ran the car cold without the MAF plugged in and no misfire, so it's a faulty MAF... Gonna replace it with another Bosch (which it had originally) and avoid carquest. I appreciate everyone's help/advice. I can upload pictures if you'd like?
 

· Super Moderator
Go ahead, blame me. Everybody does 🙄
Joined
·
18,186 Posts
In my case, whenever I unplug the MAF it comes up with the service traction control message. It's weird. When my Bosch MAF failed, it came up with the "Service Traction Control" message, then a CEL afterwards. Got the new MAF, installed it, and the message went away (and the CEL after clearing everything).

I also ran the car cold without the MAF plugged in and no misfire, so it's a faulty MAF... Gonna replace it with another Bosch (which it had originally) and avoid carquest. I appreciate everyone's help/advice. I can upload pictures if you'd like?
It does sound strange, but it IS true and also happened to me recently.

When the MAF is unplugged with the engine running you will see goofy codes that don't correlate to the MAF.
I neglected to plug in my MAF harness after some recent work on my Tahoe and received "Service Traction Control ", "Service Stabilitrak", and " Service ABS" as well as corresponding lights on the dash. Plugging in the MAF cleared them all instantly.

I concur with NorthernSRX. Check for codes and run Mode 6 tests.
 

· Super Moderator
Go ahead, blame me. Everybody does 🙄
Joined
·
18,186 Posts
ps Torque Pro can run mode 6. I generally leave a dongle in OBD-II cars and use TP first. Then decide what to do next.
I usually decide what to do first and use TP for #2. :D
 

· Registered
2011 Cadillac CTS Coupe Premium 3.6L DI
Joined
·
8 Posts
Discussion Starter · #12 ·
It does sound strange, but it IS true and also happened to me recently.

When the MAF is unplugged with the engine running you will see goofy codes that don't correlate to the MAF.
I neglected to plug in my MAF harness after some recent work on my Tahoe and received "Service Traction Control ", "Service Stabilitrak", and " Service ABS" as well as corresponding lights on the dash. Plugging in the MAF cleared them all instantly.

I concur with NorthernSRX. Check for codes and run Mode 6 tests.
Will do! Gotta purchase a Tourqe Pro dongle and will run mode 6 and give you guys an update. Gonna return my current scanner too.

I managed to get another Bosch installed, and am gonna do another cold start once the car cools down.

On another note: The car stored a permanent code for a faulty MAF sensor when I had the bad one in there.
 

· Registered
2011 Cadillac CTS Coupe Premium 3.6L DI
Joined
·
8 Posts
Discussion Starter · #14 ·
An Update: The Bosch MAF I put in stopped the misfiring on a cold start. Now, I need to change my sparkplugs as it idles a little rough (It's due for a change anyways as it was last changed at 100k miles). I really appreciate everyone's help! Thank you! I'm definitely avoiding carquest.
 

· Registered
08 CTS DI
Joined
·
3,384 Posts
An Update: The Bosch MAF I put in stopped the misfiring on a cold start. Now, I need to change my sparkplugs as it idles a little rough (It's due for a change anyways as it was last changed at 100k miles). I really appreciate everyone's help! Thank you! I'm definitely avoiding carquest.
Bosch should be the original equipment sensor. Any difference in the inside diameter of any two MAF sensors spec'd for the car will yield a slight difference in tune as a result of the effect of intake air velocity over the sensor. Narrower than stock will make it run a little richer and larger will make it run leaner.

Traction control errors can be triggered by MAF and fueling irregularities. This happened to a family members 3.6L that had the in tank fuel pump outlet elbow leak, also known to happen to the CTS. Sniff around the right rear of the car for the smell of gasoline fumes just in case.
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top