Cadillac Owners Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have an 2005 CTSV with a Maggie. I just replaced the engine. The engine is turning over but will not start, its getting fuel. The codes it is throwing are p0118, c0281, c0550. The temp is reading over 300 degrees, I pulled the plug off of the sensor and it still reads over 300 degrees. Maybe the plug and or wires were damage when I took the engine out...I dont know. I checked all the engine grounds and they appear good grounds. The cam sensor, crank position sensor, and Temp sensor are brand new...any advice would be great...thanks
 

·
Registered
2007 CTS-V
Joined
·
33 Posts
The codes don't really have a quickly identifiable common component. C0281 is a seconddary DTC behind C0550 (master). Most likely cause of C0550 is a poor ground - check G110 (In the engine compartment, on the right frame rail, near the ABS module) AND G105 (In the right side of the engine compartment, on the inner fender wall near the battery) as the path for this ground is through the body.

The P0118 code doesn't make sense with your indicated 300 Degree temperature - P0118 means the Engine Coolant is suspected to be stuck low...

I would suggest some back to basics troubleshooting:

1) You said it's getting fuel - where - at the rail or are the injectors firing?
2) Do you have spark?
3) You can check your Crank Position Sensor by watching for RPMs on a scan tool live data while cranking.

Further troubleshooting would depend on the above.

I will throw in I'm jealous of your Maggie - I was sad to find they're no longer available when I got my Gen 1 V.
 
1 - 2 of 2 Posts
Top