Cadillac Owners Forum banner
1 - 20 of 78 Posts

·
Registered
2014 ATS AWD Premium
Joined
·
12 Posts
Discussion Starter · #1 ·
My gf has a new ATS, and yesterday she said it wasn't driving smoothly. We just put a couple thousand miles on it on a roadtrip last week. On her way to work this morning, it continued, and the TC off light came on, and pressing TC button doesn't turn it back on. Additionally, now it says service stabilitrak.

Is it safe for her to drive it? She has an hour drive home, and then another 45 mins to the dealer we bought it at. (We need to go in to get the title and plates also!)

Speedometer Auto part Measuring instrument Odometer Tool
 

·
Registered
ATS 2.0t awd premium
Joined
·
412 Posts
Sounds like it could be the pistons or rod bearing issue. If they have to do engine rebuild and the car is a lease have them fix it, if she bought financed the car then i would demand new vehicle from gm. Just my opinion.
 

·
Registered
2013 ATS AWD 2.0T
Joined
·
23 Posts
My gf has a new ATS, and yesterday she said it wasn't driving smoothly. We just put a couple thousand miles on it on a roadtrip last week. On her way to work this morning, it continued, and the TC off light came on, and pressing TC button doesn't turn it back on. Additionally, now it says service stabilitrak.

Is it safe for her to drive it? She has an hour drive home, and then another 45 mins to the dealer we bought it at. (We need to go in to get the title and plates also!)


I had a similar problem while driving. I pulled into a parking lot while it was happening, put it in park, the car stalled. I re-started, car was running very rough, T/C light was flashing on and off. I shut it down and re-started 5 minutes later and it ran fine. I was close to my dealer, so I dropped it off. They diagnosed an intermittent electrical connection within the T/C system. They ended up replacing the ECM.
That was 4 months, 8,000 miles ago, and the car has been running perfectly.
 

·
Registered
ATS 2.0t awd premium
Joined
·
412 Posts
Hopefully it's only an electrical issue, but I would take it to the dealer as soon as possible. If she doesn't feel safe driving it call cadillac customer care, maybe they can use your roadside assistance to tow the vehicle. Would hate to have something major fail while driving the vehicle. If the car was running that rough I wouldn't let my wife drive it just in case the power steering went out, as most young women she would have no idea what to do.
 

·
Registered
2014 ATS AWD Premium
Joined
·
12 Posts
Discussion Starter · #5 ·
Thanks for the advice. It's owned, so will definitely push for a new car if it needs an engine rebuild! She said she feels safe enough to drive it home. And then I'll drive it to the dealer this afternoon if she's home early enough.

The car has been amazing so far. The family was a little weary of the reliability of an American car. I hope they were wrong. Also hope they give a loaner in case it can't be fixed today.
 
G

·
I know of at least 1 user who had a rebuild from this issue...My experience with this is very different than any others I've seen...And mine's actually at the shop right now for it...When I get the Service Stabilitrak error, my hill assist doesn't work and my EPB doesn't automatically release...So mine seems to be related to the rear braking system...I don't notice any performance degradation...Seems that error covers quite a gamut of problems...Mine only comes on when I first start the car, meaning it never comes on after the cars been running for a bit...2nd time it's been in the shop for it...1st time they replaced some sensor in that rear brake assembly...

I'm assuming you've got the 2.0T? I think that's the one I read is having the issue with some of the engine internals...

In that pic you have 2 yellow warnings...is the top one because you switched TC off or do they both come up at the same time? When you turn the car off and restart they stay on? Does it ever run as it should since that warning came on?
 
G

·
Nice car...

I'm sure our issues are different but I thought I'd tag an update to your thread because our errors were the same so anyone searching in the future may find this useful in this thread...Just got off the phone with the service department...They have order a new EBTCM - Electronic Brake and Traction Control module...Fingers crossed this resolves my issue...and good luck with yours...
 

·
Registered
2014 ATS AWD Premium
Joined
·
12 Posts
Discussion Starter · #9 ·
JeffATS said:
In that pic you have 2 yellow warnings...is the top one because you switched TC off or do they both come up at the same time? When you turn the car off and restart they stay on? Does it ever run as it should since that warning came on?
The TC switched itself off at the same time.

I'm in the passenger seat on the way to the dealer now. The warnings/alerts are all off now. But I can feel a little bump whenever she accelerates or breaks. Could that be the transmission roughly switching gears?
 

·
Registered
2014 ATS AWD Premium
Joined
·
12 Posts
Discussion Starter · #10 ·
Waited at the dealer 1.5 hours while they ran tests. They're not sure what it is yet, but were able to observe the problem. Their early guess was a bad fuel injector. Got a loaner standard 2.5 (yuck). Fingers crossed.
 
Joined
·
12,902 Posts
Hello ElanX,

I am sorry to hear of the vehicle concerns your girlfriend recently experienced with her new ATS. I am glad you were able to bring the vehicle into your local dealership and they are in the process of a diagnosis. If you would like to keep me updated throughout this process, or if you have additional questions, please feel free to send me a private message.

Sincerely,

Laura M.
Cadillac Customer Care
 

·
Registered
ATS-V
Joined
·
321 Posts
I think I was the first to report this issue here. I hate to be the bearer of bad news but it's a bad piston(s). I had the exact same thing happen to me a few weeks ago and shortly after that, another member here had similar issues. Luckily, there is a TSB out for bad pistons on the ATS/Malibu so it will be free to fix. Expect 1-2 weeks of downtime.

PI1178 ATS/Malibu Engine run rough with check engine light (CEL) on. Low compression on cylinder with misfire, DTC P0300 set.
Replace pistons and rings.
 

·
Registered
2014 ATS AWD Premium
Joined
·
12 Posts
Discussion Starter · #13 ·
db_outlaw said:
I think I was the first to report this issue here. I hate to be the bearer of bad news but it's a bad piston(s). I had the exact same thing happen to me a few weeks ago and shortly after that, another member here had similar issues. Luckily, there is a TSB out for bad pistons on the ATS/Malibu so it will be free to fix. Expect 1-2 weeks of downtime. PI1178 ATS/Malibu Engine run rough with check engine light (CEL) on. Low compression on cylinder with misfire, DTC P0300 set. Replace pistons and rings.
Was it perfect once fixed at least?
 

·
Registered
2014 ATS Luxury 2.0t AWD
Joined
·
71 Posts
I too have just experienced this today, and dropped the car off at the dealer. My codes were P0299 and P0300. Cant wait till i get the call tomorrow and they say they wont fix it because of the downpipe/tune... but now im prepared knowing there are others with the issue and there is a TSB. What is the TSB number?
 

·
Registered
2014 ATS AWD Premium
Joined
·
12 Posts
Discussion Starter · #16 ·
The dealership called and said it's the fuel injector. GM is sending a new one, and the car should hopefully be ready in another day. Does this sound right? Is a fuel injector a big deal? I hope they're right, cause it definitely sounds like @db_outlaw 's piston problem.
 
Joined
·
12,902 Posts
Hello ElanX,

I am glad that your dealership was able to diagnose your vehicle and ordered a vehicle part for repair. If you would like to further discuss your situation, please feel free to send me a private message.

Sincerely,

Laura M.
Cadillac Customer Care
 

·
Registered
2014 ATS AWD Premium
Joined
·
12 Posts
Discussion Starter · #19 ·
Shooter2384 said:
Mine has a hole in one of the Pistons...
Ouch. They figured that out quickly at least. Did they say how long it would be? What were the symptoms? Hoping something different than mine a little.
 
1 - 20 of 78 Posts
Top