Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
2009 CTS4 2007 STS
Joined
·
298 Posts
Discussion Starter #1 (Edited)
While taking the kids on a drive today, for about 2 hours somewhere doing the trip the service engine light came on. This light has only came on a times usually when I floor it. I pulled the codes and it was always the mass airflow performance sensor and once for a P1527 for transmission range to pressure switch correlation what ever that means. I had an alternator put on Tuesday and a camshaft position sensor. the parts store gave me the wrong sensor so the mechanic had to put the old one back on but the service engine light did not come back on. I checked the codes today but none were current and I had a history for a:
P0174 Fuel trim system lean bank 2
B1552 Keep alive memory error
B2710 Passkey open/ shorted pellet
The car seems to run fine but there is a whirling noise coming from under the hood and it felt like it was kind of hesitant while on the highway. Is there a reason why the light would come on with no codes and I dont recall these codes ever being current.:hmm: One more thing there is a slight ticking sound once the car is warmed up but not all the time. haven't done a WOT since i got the car back. Exactly what does the P0174 code mean. Trying to troubleshoot with out going to the dealer.
 

·
Registered
Joined
·
50 Posts
It means the front bank of your motor is lean, maybe a vacuum leak. But since it only happens on wot I would check the fuel filter it may not let enough fuel to pass on heavy acceleration causing the one bank to run lean one tank off bad gas can restrict fuel filter
 

·
Registered
2009 CTS4 2007 STS
Joined
·
298 Posts
Discussion Starter #3
caddypete said:
It means the front bank of your motor is lean, maybe a vacuum leak. But since it only happens on wot I would check the fuel filter it may not let enough fuel to pass on heavy acceleration causing the one bank to run lean one tank off bad gas can restrict fuel filter
OK that make since that would explain the noise I hear under the hood but why would the service engine light still be on with no current codes the ones listed are under history and how do I find out if I have a vacuum leak and where do i need to start looking. With the work I had done to the car there could be a hose loose but I don't know where to start looking:hmm:
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,781 Posts
If the light is on, there has to be a code, and there is. It probably went historical after it set. Most likely the vacuum leak. A stethescope would be a big help in locating a vacuum leak. Just start listening around all the hoses. Don't over look the vacuum reservoir under the battery tray.
 

·
Registered
Joined
·
54 Posts
When check engine light comes on before you turn engine off check for codes with engine running. Once you turn off the engine your code will show history.
 
1 - 6 of 6 Posts
Top