Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
95 ETC. 66 Impala 427 Sport Coupe
Joined
·
23 Posts
Discussion Starter #1
What plugs and wires do you suggest for a 100k N*?

I was thinking of the Bosch premium plugs and a performance wire like MSD. :stirpot:
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
71,108 Posts
For some reason, on average Northstar + Bosch = Nightmare.

Your car takes ACDelco #41-950 Professional Platinum plugs. Good for 100,000. Same brand of wires. MSD and ACCEL, Taylor, Moroso, and other aftermarket wires are eye candy and do nothing for the engine.

Take a look at your car, ignition, in www.rockauto.com.

EDIT: You'll notice that the ACDelco Platinums are made in Japan. Any bets that they are made by DENSO, the original plug supplier for the Northstar series ???
 

·
Registered
1997 Cadillac STS (BOSE w/AUX In, Massage Seats, URPAS, "Z")
Joined
·
6,405 Posts
Stay away from Bosch!
I had in my car and worked well for almost 5K. Then as per everybody’s advice I switched back to AC Delco (about half the price) and never looked back in the 60K or so since.
Your car is one of the best ever, there is nothing aftermarket to work better (that’s Honda/Toyota/Mazda and such territory).
Same goes with wires, everything else is placebo and blink, blink!
 

·
Registered
1994 Eldorado
Joined
·
18 Posts
well i put in the bosch platinum +2's and my car has been running like a beauty ever since...u guys are making me nervous. why no bosch?
 

·
Registered
1997 Cadillac STS (BOSE w/AUX In, Massage Seats, URPAS, "Z")
Joined
·
6,405 Posts
daver123,
First thing I changed on my car when I bought it was the spark plugs (Bosch Platinum 4) for almost no reason, worked great for almost 5K the I started getting misfires, rough idle I mean the whole shebang.
Everybody here told me the same thing AcDelco spark plugs, but I could not believe the spark plugs can go bad in 5K (especially such a fancy expensive ones). So I tried everything but the spark plugs, eventually ~10K the car was almost undrivable (literally). So in desperation I changed the spark plugs with AcDelco (as per everybody's advice), back to butter...70K later still butter. Now I still have a slight rough-ish idle (maybe is just in my head though) but definitely not the plugs, as I mentioned once, I remember waiting on a traffic light and some how I was annoyed by the vibrations caused by the intermittent ON/OFF of the wipers (that was above the idle) so maybe is just in my head (I had my 2 mechanics in the car and none felt any idle roughness but still I thing is something).
Hope yours will be better...
 
1 - 8 of 8 Posts
Top