Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
98 seville sts
Joined
·
103 Posts
Discussion Starter #1
I am excited about my 98 sts. It had a couple of minor problems like it needed a water pump. we did that but the on board computer dash still says check coolant level. Is this a computer re set issue and do I just plung my computer in like I am geting codes, then erase to make the message go away. Thanks
 

·
Registered
Hyundai Elantra
Joined
·
18,816 Posts
Welcome to the forum! :wavehi:
 

·
Registered
1992 STS / 2005 MB G500 / 2003 STS / 2006 XLR-V
Joined
·
11,694 Posts
I am excited about my 98 sts. It had a couple of minor problems like it needed a water pump. we did that but the on board computer dash still says check coolant level. Is this a computer re set issue and do I just plung my computer in like I am geting codes, then erase to make the message go away. Thanks
Two possibilities... One is the sensor in the bottom of the surge tank is bad and you will have to replace the tank. If you have added the specified level of coolant and the car continues to show the message as soon as you start it this is the most likely cause (with no obvious leaks on the ground of course).

The other possibility is the car is actually using coolant, most likely due to headbolt/headgasket failure. Low coolant warnings are usually the early signs of this followed by overheating. Do a search for "headgasket" in the Seville and Northstar mechanical forums for all the info you ever wanted.

I am redirecting this thread to the appropriate forum for you. Welcome!
 
1 - 4 of 4 Posts
Top