Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
2006 CTS-V
Joined
·
4,969 Posts
Discussion Starter #1
I'm getting code B2556H. Its for interior lamp from what I've read, but my headlights seem to be the issue. Even when the car is off, lamp switch is in auto or off, and its locked, twilight timer = 0, and still won't shut off. I'm guessing fuse? I'll be checking the fuses in a minute here.
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,802 Posts
Sounds like the relay for the headlights is stuck ON. Are the headlights the only thing on, or are the parking lights too?
Either way, remove the relay for the headlights there maybe two of them, I'm not sure.

KOT
 

·
Registered
2006 CTS-V
Joined
·
4,969 Posts
Discussion Starter #3
Sounds like the relay for the headlights is stuck ON. Are the headlights the only thing on, or are the parking lights too?
Either way, remove the relay for the headlights there maybe two of them, I'm not sure.

KOT
Its definitely the parking lights. However, I removed all the fuses, they were all good... put them back and nothing.
Taillights, side marker lights, triangle and headlights all stay on. Trying to change 'em from the stick won't change.
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,802 Posts
You didn't mentioned if you check the relays. And since you are saying that the parking lights and the headlights are stuck on. It maybe a computer issue here. Quick question, does the "dummy bong" come on when you open the door as if you left the light switch in the on position? No matter if it does or not, I want you to test this out. First leave it in the Auto, open the door does it sound? Then try each other position, does it sound at any other or all?

KOT
 

·
Registered
Joined
·
1 Posts
I'm getting code B2556H. Its for interior lamp from what I've read, but my headlights seem to be the issue. Even when the car is off, lamp switch is in auto or off, and its locked, twilight timer = 0, and still won't shut off. I'm guessing fuse? I'll be checking the fuses in a minute here.
I'm having this same issue on my 2008 CTS. How did you resolve this problem? Lights stay on when the car is off, changed all to light settings to off on approach and departure. I have not checked fuses or relays..
 
1 - 6 of 6 Posts
Top