Cadillac Owners Forum banner

1 - 11 of 11 Posts

Registered
2013 CTS Performance Coupe
Joined
15 Posts
Discussion Starter #1
2011 CTS Sport Wagon. I had the LF wheel bearing replaced. All is well. 600 miles later while driving the freeway, the ABS, TC, Stability, Brake assist, AWD inop, message came up on the dash. The only lights were the ABS & TC. I put my scanner on it and no DTC's. I thought maybe the wheel speed sensor connector might be unplugged. { I haven't been under yet to check.} A friend suggested that I disconnect and reconnect the battery. The owners manual just says to get it serviced. Duh. Any ideas?
 

Registered
Go ahead, blame me. Everybody does 馃檮
Joined
9,920 Posts
A "better" reader than the one you used will tell you the problem.
 

Registered
2008 CTS Base Manual Tran
Joined
553 Posts
I believe a bad wheel hub sensor will trip all of those lights. An ABS capable scan tool will identify the offending wheel or provide guidance on the problem if the wheel sensor is not the issue.
 

2011 CTS Coupe Premium
Orlando - We take orphans
Joined
3,019 Posts
If disconnecting the battery always disconnect the negative side first or only. Good German electronics.

ps an Autel Diaglink is under a Benjamin and tells all.
 

Registered
2013 Black Diamond CTS4 Premium Coupe (sold-09 CTS4 DI Black Raven/Ebony)
Joined
4,378 Posts
If you disconnect the battery, be sure to reset the TPS properly after reconnecting the battery. Instructions are in the owners manual.
 

Registered
'12 CTS Performance Sports Wagon AWD
Joined
2,949 Posts
I suspect you have a bad hub ring on the front again. It appears when a rear hub goes bad the AWD does not kick out. When a front hub goes out it does. Could be the other side died too or the one you had put in was installed improperly or was damaged.

My 2012 Sport Wagon AWD had like the rear right hub go bad and then the week later the front left one went bad. Was just their time. I had had the car for about 6 months before the first hub died. Luckily I still had two hubs I had bought from RockAuto for my sedan that I had so it was not a big deal to swap them out. I bought a special tool for it and now I can change a hub in about 2 hours.
 

Registered
Go ahead, blame me. Everybody does 馃檮
Joined
9,920 Posts
Hub Buster.
 

Registered
'12 CTS Performance Sports Wagon AWD
Joined
2,949 Posts
Hub Buster.
Yup... Bolts on to a couple of the lugnuts then you hammer on it in both directions until the hub pops off.
Of course you have to loosen the 3 bolts that hold the hub in place.

Rodney
 
1 - 11 of 11 Posts
Top