Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
2007 1SG STS v8 awd
Joined
·
502 Posts
Discussion Starter #1
I recently changed my o2 sensor. Engine light is off but I still have hesitation and a misfire under heavy acceleration or under load. I. Thought the o2 sensor was causing this. If I accelerate hard the engine light would flash along with the tc light coming on. It would then both go off. What could possibly be causing a misfire under load/acceleration? And not throwing any codes setting off the engine light. If the light would come on I would have somewhere to start.
 

·
Registered
2005 cadillac STS AWD 1SG
Joined
·
531 Posts
DTC should be in memory even if check light doesn't lit. So check for DTC first.

Spark plugs and coils are the main reason that could be.
 

·
Registered
2007 STS-V
Joined
·
193 Posts
If the O2 sensor was bad, you could have been running rich for some time causing plug fouling. You probably need to reset the computer with a battery disconnect and new plugs. Changing the sensor just gets it back within correct mixture rating, it does not clean the plugs from running too rich.
 

·
Registered
05 STS 1SG v8 RWD
Joined
·
71 Posts
just a thought, but.
when you said TC light coming on did you mean Traction control?
if so, you could have something wrong with your traction control system, you said that this is happening under heavy acceleration. I know my car will spin if I step on it.

if your tires are loosing grip and there is an issue with the traction control then this could be causing the hesitation.
also if the wrong signal is being sent to the engine then this would cause the engine light to flash.
 

·
Registered
2007 1SG STS v8 awd
Joined
·
502 Posts
Discussion Starter #5
It's not wheel spin at all. The tc light just comes on when the engine light is flashing that's all. And the engine light finally came on giving me a code p0300 random misfire. What the hell could it bed now. All the 02 sensor codes are gone but now this. Where do I start. Coils, plugs, fuel injectors what. It is possible I fouled the plugs so I may start there. Even though I just changed the plugs last year.
 

·
Registered
2005 STS4
Joined
·
10 Posts
I dumped tons of $ in my sts4 trying to figure out a misfire. Took it the the stealer where I spent around $500, but ended up being a short in a wire coming from an injector. Had to run new wires from there to the ecu.
 

·
Registered
2007 1SG STS v8 awd
Joined
·
502 Posts
Discussion Starter #7
STS4va said:
I dumped tons of $ in my sts4 trying to figure out a misfire. Took it the the stealer where I spent around $500, but ended up being a short in a wire coming from an injector. Had to run new wires from there to the ecu.
. Who found the issue and how did they find it. A random misfire code sucks cause it's like a guessing ?game

----------

B1n2fra said:
. Who found the issue and how did they find it. A random misfire code sucks cause it's like a guessing game
 
1 - 7 of 7 Posts
Top