Cadillac Owners Forum banner

1 - 15 of 15 Posts

·
Registered
Cadillac
Joined
·
11 Posts
Discussion Starter #1
i had an oil change about a week ago and until today things have been good. While driving to work, i was at a stop light and i received a "Low Oil Pressure. Stop Engine" warning plus the oil light came on. As soon as i started driving again the warning and light went away but kept coming on at each stop light/sign. Any ideas on what to check for? I have a 2004 SRX with a 4.6L v8 Northstar engine.
 

·
Registered
2008 SRX Sport Pkg
Joined
·
1,135 Posts
Did you put in enough oil? According to the manual, the 4.6L V8 Northstar requires 8 quarts (or 7.6 L) of engine oil. If you only put in a gallon, you run the risk of starving it of oil and mechanical damage can occur. Low temperatures and low engine speeds would worsen the situation to the point where the pressure drops and a warning message is sent.

If you have done all things correctly, one possibility is a bad or dirty oil pressure switch. These sometimes get fouled up and can be cleaned to prevent erratic operation.
 

·
Registered
2007 SRX4 N*, 2004 Infinity G35 Coupe
Joined
·
2,005 Posts
Good advice.......a low enough motor oil level will trigger low oil pressure and the light. I think the psi threshhold that triggers the low oil pressure light on the V8 Northstar is 6 psi. And the OP had his oil changed, didn't do it himself. I trust no one to add back in the correct amount of motor oil, always check it myself after the car has sat on level ground for a while.

More than once I have found the level a half quart low which should never happen when the techs have the spec, use it, and they should be checking the level post change. OK, a half quart is not the end of the world. But.....

One time I had a motor oil change and within the hour I was 50 miles down the road on Interstate 80 on a 300 mile road trip to Detroit. I stopped for gas, checking the motor oil level too. I was 2 quarts low!!!! No, there was no leak from the oil filter or the drain plug. The tech just blew it, pure and simple. The reason does not matter.

I immediately called the place where I had the oil changed and let them have it. They offered me a free oil and filter change to appease me. "Why would I ever trust you again to work on my car when you can't get something so simple done correctly? I'm now going to go check the tire pressure you guys were supposed to check. " Then hung up. Yup, 2 psi lower on all 4 tires than I had requested. They were just as proficient (NOT) at that simple task too.

Lessons learned.

PJ
 

·
Registered
Cadillac
Joined
·
11 Posts
Discussion Starter #5
after letting it sit a while checked the oil level and it came up fine. I also started it up and let it idle a bit without DIC indication warning or oil light coming on.

----------

where is the sensor located so i can try cleaning it??? thanks for all the advice ;-)
 

·
Registered
05 srx awd v6 (gone), '07 GXP, 2010 li'l red wagon 3.6
Joined
·
3,177 Posts
It's on the oil filter adapter near the top, looks to be facing forward. Manual says to remove adapter to remove sensor. Need more?
 

·
Registered
Cadillac
Joined
·
11 Posts
Discussion Starter #7
@Glake89...any details would be great...i am definitely no mechanic. appreciate that. BTW...i checked the oil level again after it sat for a few hours and looks full...no oil leak visible either. i drove it around the block a few times and no warnings/lights/indications...i just hope it doesn't pop up on my way home!
 

·
Registered
05 srx awd v6 (gone), '07 GXP, 2010 li'l red wagon 3.6
Joined
·
3,177 Posts
Well, it's not easy to get to so if no more codes or trouble, maybe leave well enough alone. In the meantime, stop by a parts store and ask them to read your DTCs. Let us know what they are.
 

·
Registered
Cadillac
Joined
·
11 Posts
Discussion Starter #9
Well, i got home fine yesterday but today as i got to work, i stopped for gas and as soon as i put the car in park, the same warning came on. I shut the car off, got my gas, checked oil level and it was normal. Got back in...no warnings...got to my office no problem. Very frustrating but i'll check into the DTCs. Thanks again!
 

·
Registered
2010 CTS AWD Wagon 2010 BMW X5 35D 2008 GL320
Joined
·
2,623 Posts
You have a pressure not a level problem, they are different.

You can still have good oil pressure with low oil level, ask the V6 guys.

So you need to see what's going on with your oil pressure, you have low oil pressure or the ECU thinks you have low oil pressure.

Can you get one of the those real time scan tools to monitor and/or log oil pressure? Now this will only tell you what the sensor sees, the only way to see oil pressure is with a gauge plumbed in but the scan will be a good start.
 

·
Registered
Cadillac
Joined
·
11 Posts
Discussion Starter #11
@Conedoctor: Thanks for the info. Was just checking levels as this was something i read about. Will definitely have to check the pressure out and see what's going on. it's just so frustrating when it comes and goes like that.
 

·
Registered
05 STS4
Joined
·
4,241 Posts
Do not drive the car. It has that warning for a reason. You will damage the bearings if you continue if you haven't already. There's a real the car is saying to shut it off.
 

·
Registered
2007 SRX4 N*, 2004 Infinity G35 Coupe
Joined
·
2,005 Posts
Can't the oil pressure psi drop low enough to the threshold and trigger the low oil pressure light if the idle rpm is low enough.....yet not so low as to cause the engine to stumble or die? I am no mechanic either. Just wondering as I follow this thread.

PJ
 

·
Registered
2010 CTS AWD Wagon 2010 BMW X5 35D 2008 GL320
Joined
·
2,623 Posts
I would not get too worried right now as the warning goes out and if you lost oil pressure you would know it, you may have a pump going bad and loosing pressure as flow slows down, you could also have a bad bearing killing your oil pressure and letting it all out.

Other thing would be a suction issue that resolves itself but usually a suction blockage gets worse if you increase the pump speed.
 

·
Registered
Cadillac
Joined
·
11 Posts
Discussion Starter #15
so far i've had no problem with noise or starting or anything with the engine...planning on checking the DTCs on my way home. really hope it's just a bad or dirty oil pressure sending unit.
 
1 - 15 of 15 Posts
Top