Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
I have a 1984 Eldorado 4.1. The oil pressure switch was not working so I installed a new one which works fine. When I apply the brakes and am almost at a complete stop The "Stop Engine Low Oil Pressure" light comes on. It then gradually dims and then goes out. ( a few seconds total)

The light never comes on when at idle or while driving. I have checked the level and it is fine.

:confused:

84ELDO
 

·
Registered
Joined
·
117 Posts
Check the oil pressure sender.. it could be a problem as well as if the wires are melted or somebody just decided to tape them.. just snoop around that area to see if you notice anything that doesnt look right
 

·
I'm a Cadillac Fanatic!
Joined
·
9,575 Posts
Did you install an OEM oil pressure switch or an aftermarket generic replacement?


The OEM switches have a different setpoint than some of the aftermarket generic parts. When the oil pressure dips low as the engine comes down to idle the oil pressure warning will trip if it is not the correct switch.....
 

·
Registered
87 Deville
Joined
·
630 Posts
84ELDO said:
I have a 1984 Eldorado 4.1. The oil pressure switch was not working so I installed a new one which works fine. When I apply the brakes and am almost at a complete stop The "Stop Engine Low Oil Pressure" light comes on. It then gradually dims and then goes out. ( a few seconds total)

The light never comes on when at idle or while driving. I have checked the level and it is fine.

:confused:

84ELDO

Could be that the idle is set too low, That would also cause the light to come on while in drive at a stop. My 4.1 started doing the same thing right after the (TPS) Throttle Position Sensor was adjusted, so it may just need to be adjusted. The TPS senses throttle movement and position, then transmits a voltage signal to the ECM to determine when the throttle is closed, or in a Cruise position OR wide open. Let us know what you find out ok.
 
1 - 4 of 4 Posts
Top