Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
18 LEXUS LX, 17 Rav4, 15 Escalade ESV, 14 Mercedes, had Vette, 2Cadis, T-B & Chevy
Joined
·
1,041 Posts
Joey,
Congratulations
and sorry the the 2015 put you through all that trouble.
Glad your 2015i is working great.

All of the months I complained on here with the issues on my 2015 Escalade I just want to let everyone know that I love this new rig. Everything works great and I have no complaints at all!
I am at 1200 miles and she floats……….

Joey Rosario
View attachment 292785

George
 

·
Registered
Joined
·
5,309 Posts
You got lucky then! Our 2015i Escalade has been plagued with issues since about 2,500 miles. Just pray your transmission is ok. If you feel a clunk on acceleration, you will need a new transmission. They replaced ours last week.

When was yours built? I hope for your sake it was a factory fresh unit and built recently.
 

·
Registered
09 escalade
Joined
·
540 Posts
It's good you are loving your truck
It does look sharp.
Since its a later built its probably has way less issues.

I like how my truck looks,how improved its compare to older one but I hate vibration&buffeting in the cabin
How rear seat climate control and heated seats comes on ramdomly and so many problems here and there.
Now I also know my headaches and dizzyness last year is caused by the vibration and buffeting in the vehicle.
 

·
Registered
None
Joined
·
226 Posts
Having no issues what so ever with my plain old 2015 WD ESV premium with kona brown leather and automatic running broads 11,000 miles. No vibration or buffering sound what so ever. My only qualm is that I couldn't wait for the platinum to come out I had to have it right away . Lol oh well it's still sharp truck minus the old badge. My 4 WD worked very fine in these northeast winter we just had .

----------

Oh and congrats Joey mine looks just like it but ESV.
 
1 - 7 of 7 Posts
Top