Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
2007 Escalade, 2005 CTS
Joined
·
788 Posts
Discussion Starter #1
just recently, i lost all chimes, the front door speakers and tweeters, the turn signal tick noise, and the beep from backing up getting too close to an object. Any ideas? then it started working again for about an hour or 2, next morning back to not working. I know someone had the same issue and replaced the amplifier and that didnt fix it. Everything is connected properly. Fuse maybe?
 

·
Registered
2007 Escalade base
Joined
·
104 Posts
Check and make sure the left front door speaker is working, That is the one speaker that all that sound comes from. I have seen this a few times and it turned out to be a bad speaker.
 

·
Registered
2009 escalade hybrid
Joined
·
3,744 Posts
Usually a software update fixes it. I also noticed that if a laptop is plugged in the 120V outlet of t hybrid it makes the same scenario. The software update did fix it though.
 

·
Registered
1999 Escalade, 2004 CTS, 2003 ESV, Now 2008 Escalade
Joined
·
1,279 Posts
Sometimes if you unplug the battery and plug back in it goes away. Mines happens once in a blue moon and I remove a fused and plug back in and it works again. It might come back
 

·
Registered
2015 Escalade and 2018 CTS-V
Joined
·
320 Posts
If audio is playing through your speakers, the only 2 other possible issues is the radio output or the amp. I dont know the exact situation with that person that replaced the amp and it still didn't work, but that's where I would start... the amp. If you have Navigation, check if the nav audio works. If not, has to be the amp.
 
1 - 5 of 5 Posts
Top