Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Cadillac
Joined
·
36 Posts
Discussion Starter #1
I had the truck in the shop to have the sound system installed and got a check engine light after the battery died.. put a jump pack on it and it started right up but he engine light stayed on.. also the truck had to idle for a long time while they worked on the sytem and the tranny temp was way up... The reason I'm bringing this all up is the truck was extremely sluggish on the way home.. Is it in limp mode for some reason ? Its a 2005 with 54,000 miles
 

·
Registered
99 Escalade (sold) 03 Escalade EXT (sold) - 07 Escalade EXT
Joined
·
1,363 Posts
the shop probably idled it for a while to keep the battery from dying... why would that cause the trans temp to go up? that doesn't seem logical...
 

·
Registered
'01 Pearl White - Sold 10/11, '09 Raven Black :)
Joined
·
737 Posts
So you're saying the tranny temp was up while they worked on it or while you were driving it? Does not make sense if it went up while it was idling considering that it is not really doing any work... hmmm interesting problem here - let us know the outcome!
 

·
Registered
1992 STS / 2005 MB G500 / 2003 STS / 2006 XLR-V
Joined
·
11,694 Posts
Ditto with the above, there is no reason your trans temp should be increasing from simply idling. I'd be more suspicious of the temp gauge itself, especially with all the battery and electrical snafus you just experienced.
 

·
Registered
Cadillac
Joined
·
36 Posts
Discussion Starter #5
checked the codes this morning when I got up.. 3 tranny codes ..torque conv. solenoid A.. solenoid B.. called the dealer and he said it probably needs a reflash
 

·
Registered
Cadillac
Joined
·
36 Posts
Discussion Starter #6
Took it to the dealer.. it was one wire tapped into the circuit that controls the shift points and the clutch.. 5 mins and all good...
 
1 - 6 of 6 Posts
Top