Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Cadillac
Joined
·
19 Posts
Discussion Starter #1
When looking at my car from behind ('99 STS) when it's lights are ON, the left half of the LED brake light bar is weakly lit in comparison to the right, and also the left hand side red lensed rear light is off.

Could anyone shed any light on this please? Perhaps a fuse?

Thank you

Dale
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
69,104 Posts
:thumbsup: Go with Ranger, and while you have the rear trunk area opened up (most of the lighting feeds come in from the rear fuse box, BTW), look at the filament bulbs and if they look dark or with saggy filaments, change the whole batch and go another 8 years......including the 194's in the license sockets, which means you'll have to drop the trunk lid liner to pull the center lighting assemblt. Not a hard job, actually. (You might Google a Sylvania bulb replacement list for your car......use Long Life bulbs...brighter and tougher....)
 

·
Registered
1992 STS / 2005 MB G500 / 2003 STS / 2006 XLR-V
Joined
·
11,694 Posts
Check for moisture intrusion in the CHMSL LED strip. This is the number one reason these fail. We have a member here, LoganDiagnostic, who sells the entire assembly for a reasonable price. Very common problem with those.
 

·
Registered
2000 Cadillac ETC - White Diamond
Joined
·
27 Posts
I have this exact issue with half my trunk mounted LED CHMSL is lit up and the other half lazy. Sometimes lit, sometimes flickers, sometimes not lit at all. The rear window trim CHMSL is out too. I changed the bulb and still doesn't work. Any advice on which ground is a usual culprit?
 
1 - 6 of 6 Posts
Top