Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
2001 STS
Joined
·
1,575 Posts
Discussion Starter #1
It was just brought to my attention that the brake light strip accross the trunk on my 93 SLS is not working. Ive seen half a strip working on another Lac in the past and felt very bad for him/her. Now I find that mines not working at all. :crying2:
It appears that they are quite expensive to replace.
Id like to know how I would go about checking and or testing to find out if I really need a new one. Hoping there's a bad connection or maybe a short somewhere.
Also if it comes down to it, how difficult it would be to re-build it myself ?
Or am I just grasping at straws here ?
Once its gone its gone ?
Ive already copied the instructions from Caddyinfo.com on the removal procedure..Would like to know how to verify if it's realy done or not. And if it is, how I could rebuild it myself if that would be feasable ?

:burn:
 

·
Registered
2001 DTS, 2005 Mustang GT, 2010 MINI S
Joined
·
1,121 Posts
I meant to post this here. Not a new thread.

http://www.cadillacforums.com/forums/showthread.php?threadid=3995

Logan

Murphyg said:
It was just brought to my attention that the brake light strip accross the trunk on my 93 SLS is not working. Ive seen half a strip working on another Lac in the past and felt very bad for him/her. Now I find that mines not working at all. :crying2:
It appears that they are quite expensive to replace.
Id like to know how I would go about checking and or testing to find out if I really need a new one. Hoping there's a bad connection or maybe a short somewhere.
Also if it comes down to it, how difficult it would be to re-build it myself ?
Or am I just grasping at straws here ?
Once its gone its gone ?
Ive already copied the instructions from Caddyinfo.com on the removal procedure..Would like to know how to verify if it's realy done or not. And if it is, how I could rebuild it myself if that would be feasable ?

:burn:
 

·
Registered
2001 DTS, 2005 Mustang GT, 2010 MINI S
Joined
·
1,121 Posts
Reread the post

Oh...not working at all? Ok..the upper lamp is on a different electrical circuit then the lowers. There is a area to check. The drivers side trunk hinge often can close on the trunk harness when closed. After a while this breaks the wires inside the harness. Hence no 3rd brakelight.

Pull the carpet panel out on the drivers side of the trunk hinge and inspect the harness.

Logan
 

·
Registered
2001 STS
Joined
·
1,575 Posts
Discussion Starter #4
Thanx Logan !

Didnt notice that you were here. Definately know now that I've found the place to be. Was shocked to find GMForums gone.
So from the info that you've given me I can see that re-building it myself is probably out of the question. I can take on most things myself but that could be a bit much.

Before I forget..I should have said I got the removal instructions from Logandiagnostics. Seeing as that is where I got them from ! I accesed them through Caddyinfo. Sorry about that. :worship:

Will inspect the harness this weekend. Thinkin about it now that you've brought it up. If memory serves me right, I think that the last time I was in there It might have looked kinked. Cant be sure though. Hope thats all it is !

The circuit board you refered to? Is that along the whole strip? Like a part of the whole light? Or is it off to the side where I can test it and possibly replace it?
Also... Im North here in Ontario Canada. So its not really feasable for me to be sending it South of the border for rebuild. Would you possibly know of anyone here that is cappable of helping me out?

Thanx again !
 

·
Registered
2001 DTS, 2005 Mustang GT, 2010 MINI S
Joined
·
1,121 Posts
Re: Thanx Logan !

The circuit board is sealed inside that lamp housing. Thats why they are a difficult repair.

As for caddyinfo or GMfourms. We are in no way directly connected to either one. The only things we really share are the links and info.


I think you will find your problem in the harness. Look at the harness and the drivers side trunk hinge. You have to look when the trunk is almost closed. Thats when the harness gets crushed.

As for Canada. I dont know of any rebuilders in Canada...or the US for that matter. Anyways we ship lamps into Canada quite often. With your exchange rate the lamp is about $600 new up there. It is also easier for us to ship you a replacement and then you return yours. Mostly because we use a reuseable shipping tube that the lamps can survive in.

Logan

Murphyg said:
Didnt notice that you were here. Definately know now that I've found the place to be. Was shocked to find GMForums gone.
So from the info that you've given me I can see that re-building it myself is probably out of the question. I can take on most things myself but that could be a bit much.

Before I forget..I should have said I got the removal instructions from Logandiagnostics. Seeing as that is where I got them from ! I accesed them through Caddyinfo. Sorry about that. :worship:

Will inspect the harness this weekend. Thinkin about it now that you've brought it up. If memory serves me right, I think that the last time I was in there It might have looked kinked. Cant be sure though. Hope thats all it is !

The circuit board you refered to? Is that along the whole strip? Like a part of the whole light? Or is it off to the side where I can test it and possibly replace it?
Also... Im North here in Ontario Canada. So its not really feasable for me to be sending it South of the border for rebuild. Would you possibly know of anyone here that is cappable of helping me out?

Thanx again !
 

·
Registered
2001 STS
Joined
·
1,575 Posts
Discussion Starter #6
Thank you very much Logan.
I really appreciate all the information !
I will take a look at it this weekend and see what I find. Will let you know what the situation is.

Thanks again !
Murph'
 
1 - 6 of 6 Posts
Top