Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
2007 STS4 3.6
Joined
·
30 Posts
Discussion Starter #1 (Edited)
IMG_20150212_142550380 (1024x576) (800x450).jpg IMG_20150126_114803061 (360x640).jpg

Hi, I noticed my car making a funny noise a couple of weeks ago. It was almost like a mechanical/electrical whine or whirring. I looked into what it could be and found out it was the power steering going low. I checked the car out and sure enough it's leaking from the bottom. In the attached pics you can see that the rusted metal bracket holding the rubber hoses or metal tubing underneath has rusted thru and it now leaks.

The problem is idk what this part is called or where to order it. I tried looking online at parts diagrams and nothing really seems to come up. Anyone know what just that part is called or where I can look to find out?
 

·
Registered
97 Deville, 2007 STS4 V6
Joined
·
10 Posts
Did you ever find a part number for the metal tubing? My car just developed the same leak and I cannot find the metal tubing listed anywhere!

Any help would be greatly appreciated!

Thanks!
 

·
Registered
'11 CTS-V Coupe M6, '05 1SG STS4 V8
Joined
·
377 Posts
I actually have the same leak, thought it was the hose but it still leaks after replacing it...must be the hard line. The rusted bracket just holds the lines in place I believe...haven't had time to replace the line.
 

·
Registered
97 Deville, 2007 STS4 V6
Joined
·
10 Posts
I was able to pull mine apart last night and it definitely is the hard line. It is seeping out of the tube under where the rubber support wraps around it and secures it.

Not sure how this happens, but it sounds like it may be a common problem.

I am still unsure of what the part number is, so if anyone has any luck the help would be much appreciated!

Thanks!
 

·
Registered
'11 CTS-V Coupe M6, '05 1SG STS4 V8
Joined
·
377 Posts
Maybe salt gets between it and corrodes the aluminum over time?

Isn't the hard line just beveled on each end? We could probably just get some straight aluminum tubing and have it bent to look like the original. I'm not finding a part number either.
 

·
Registered
'11 CTS-V Coupe M6, '05 1SG STS4 V8
Joined
·
377 Posts
I fixed mine today, just used rubber hose instead of hard line, ran the hose into the bracket (bend the bracket so the hose will fit snug). I also zip tied the hose to the other hard line.

I have pictures but having an issue posting them with my phone. PM if you'd like me to text them.
 
1 - 6 of 6 Posts
Top