Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
1996 Deville
Joined
·
7 Posts
Discussion Starter #1
What's up folks....problem:

My caddy('96 Deville) won't start....I mean nothing...the interior lights won't come on, radio won't come on...nothing....but the battery has a charge.

When you attempt to crank it, you can hear a clicking noise coming from the fuse box.

I don't know too much about fixing rides...any suggestions as to what may be causing this?

Oh, a little more info: Prior to my car not starting, I was at the gas station and let my radio play(car was off) while I pumped the gas. It started acting weak then...had to turn the key 2-3 times before it started up. I then went to the grocery store and car was completely dead when I came out.

Thx for any help you can provide!
 

·
Super Moderator
2010 DTS
Joined
·
87,544 Posts
This car is fuel injected, not carbureted. Pumping the gas does nothing. Sure sounds like a dead battery and the clicking sound you are hearing is not from the fuse box, but the starter solenoid under the intake manifold. How do you know it is good?
 

·
Registered
1996 Deville
Joined
·
7 Posts
Discussion Starter #3
Well, I attempted to get a boost. So I connected the booster cables to my battery...when I touched the positive and negative cords together, they were sparking.

So I was assuming the battery was good since it was giving off a spark....but maybe not, huh?
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
71,006 Posts
Don't touch the cables together on a Northstar or Cadillac engine - good way to fry a LOT of expensive modules !! Just because a battery will spark a cable doesn't mean it is fully, or even partly, charged. If the battery is more than 4 years old a load test should be performed - if it's over 6 years old, new battery.

Running the radio for the 5 minutes you were pumping gas into the tank may just have been enough to finish off a dying battery.......What voltage does your DIC display when the engine has been running at 1,500 + rpm for a while ?? The battery should charge at 14.4 to 14.8 volts.
 

·
Registered
1996 Deville
Joined
·
7 Posts
Discussion Starter #5
OK...I'm gonna take my battery to Autozone later this PM...I think they'll test my battery free of charge.

I hope that's the answer to this riddle....because I know if I take it to a repair shop, they're gonna charge me an arm and leg.

Pre-8 the advice!
 

·
Registered
1996 Deville
Joined
·
7 Posts
Discussion Starter #6
Ya'll,

It was the freaking battery like ya'll said....starting like a champ now with my new battery.

Thx for your help on this!
 
1 - 6 of 6 Posts
Top