Cadillac Owners Forum banner

1 - 20 of 27 Posts

·
Registered
2007 SRX V6 AWD
Joined
·
15 Posts
Discussion Starter #1
Well, my gf and I have been a Cadillac owner since May 10th of this year, unfortunately, it has not been a pleasant experience. Before I start, we picked up a 2007 V6 SRX.

On May 19th is when the problem started. My gf took her daugther and our son to her daughter's soccer game. When she got there, the key would not come out of the ignition and the car would not restart either. The road side assistance guy came out, and basically took everything apart he could, and could not get the key removed. So he took over to the closest dealer, got a rental (a freaking Equinox) and had the car towed there.

Well, on the 22nd, the dealer said it was a fuse. The fuse (with a 2A fuse, which seems small) was replaced (not sure which fuse), and my gf picked up her car. ONE HOUR later the same problem occurred. The same service rep (a very nice guy) came out again. The fuse was popped again (a 2A fuse) and he replaced the fuse, and they drove back to the dealership, got the Equinox back, and then waited.

Well, we waited till last night (June 6th) after they replaced a computer, which then lit up some other warnings which required more parts, that we had to wait for, and were then replaced. When my gf picked her car up last night, they didn't have her paperwork ready (so I don't know exactly what was replaced) and the driver's seat was dirty along with the hand grip on the door. So, with all that, at least we had the car back. Well, today (June 7th), she gets to work this morning, and guess what, can't get the frigging key out of the ignition. Her boss was able to get it out, but again, the car would not start. Same road side assistance guy comes out, and guess what, the same freaking 2A fuse is blown.

So the road side guy is having someone from the dealership come pick the car up and drop off a Cadillac as a rental. My gf had left a scolding message with the service manager last night about the lack of paper work (needed to recoup some of our monthly payment through Cadillac Care) and the condition of the inside of the car. To the service manager's credit, he was totally understanding, and said the car would be completely detailed, and said that there was no way she shouldn't have had her paperwork. And he also should be now on top of the situation today.

So here's the thing, in NJ, if your car is in the shop for 20 days in the first year (this is our first month), it's a lemon. Well, today is Day 20. We're not quite ready to explore that avenue, but we will be making people aware of it.

If anyone has had this problem, please let me know what resolved it. I saw one post in a search where a person could not get the key out of the ignition, but the car at least would restart. I wanted to wait to post all this hoping there was a resolution so if anyone else came upon this problem, they would know what to do to solve it. I will keep this thread alive until there is some sort of resolution.

To everyone's credit that we have dealt with, they have been good people, except for the GM of the dealership we bought the car (not the same one servicing it) who really could care less about our problem the first time it happened. Since the car arrived with 2 dings in it (that the GM has promised to fix), I'll probably give him a call just so he knows what's up. Not that he'll care.

Sorry for the lengthy post, but normally being a foreign car buyer, having so much bad experience from a GM product is painful. Trust me, I know 95% of SRXs are great cars and pretty much trouble free, but everything is based on your own experiences. I hope we can get this resolved, and have the car for 38 great months (39 month lease) since the first one has been so terrible.
 

·
Registered
04,06,10 SRX; 2011/14 CTS Wagon
Joined
·
1,803 Posts
I am sorry to hear about the chit you are going through. Hopefuly they will get you fixed up. I don't blame you for the way you are feeling. I would feel the same way. Good luck, and don't give up just yet.
 

·
Registered
04,06,10 SRX; 2011/14 CTS Wagon
Joined
·
1,803 Posts
Erik, Just talked to our key cylinder guy. He seems to think a wire was pinched at assembly somewhere. Tell you stupid dealer to quit throwing fuse's at the problem, and investigate the frickn' electrical system. Either that or put a frickn' paper clip in instead of the fuse, then when the vehicle catches fire, you will know right where the issue is. Selling our product is one thing, keeping people in them is another. I think we have a loooong way to go on the latter. Good luck, and demand action. This really cheese's me off!
 

·
Registered
2005 SRX AWD V8
Joined
·
204 Posts
Did you try unhooking the battery (for longer than 30 seconds) and then rehooking, this solved my "key wouldn't come out of the cylinder" problem.

I would hire a lawyer and start the lemon law process. It won't be easy, but no one should be treated like this, to Commit to such an expensive process and be delivered a lemon is unreasonable. I mean if 2 months after you committed to the lease you said, ummmm i don't want it any more, for no particular reason, they would flip out.

Anyways, you have every right as a consumer to be delivered a automobile that is fully functioning, ESPECIALLY right out of the gate. Just as much as they deserved to be payed on time every month
 

·
Registered
2007 SRX V6 AWD
Joined
·
15 Posts
Discussion Starter #5
Jim,

They actually have been concentrating on the electrical, well, sort of. They have replaced some on board computer. When they did that, some warning lights popped up, so they got some more parts. I would tell you what parts exactly were replaced if I had some damn paper work. Not at one point have they not realized that the issue is deeper than the fuse (still, 2A, seems kind of small). Just that everytime the car "breaks", the fuse is blown. I'll pass on the information to the service manager. Thanks. I appreciate you looking out for me.

Don, I would have to imagine the battery has been unhooked when they were doing some of this work, but I do not know this for sure. When the problem happened the first time, I was an hour away at a golf outing. Last night was the first time I have seen the car since May 19th.

Cadillac Care has sent our troubles to some regional manager. Supposedly the cadillac care person has intimated that a replacement vehicle would be a consideration but the regional manager will tell us more when they get back in touch on Monday. One positive, at least we are getting a CTS as a rental this time.
 

·
Registered
2007 SRX V6 AWD
Joined
·
15 Posts
Discussion Starter #6
Quick update. They are bringing in some recruits. Something like master GM mechanics/engineers. I forget exactly what my gf said. They'll be in Monday/Tuesday.

So it seems we bought a car with a very "special" problem. Exciting!
 

·
Registered
2007 SRX V6 AWD
Joined
·
15 Posts
Discussion Starter #7
Update - The dealer has supposedly found a wire rubbing issue near the alternator. The feel this is the main culprit to our problem. They are pretty certain we'll have the car back by tomorrow afternoon. I truly hope this fixes the problem.
 

·
Registered
1992 STS / 2005 MB G500 / 2003 STS / 2006 XLR-V
Joined
·
11,694 Posts
What the hell does a 2A fuse have to do with pulling the key out of the ignition? Is the interlock electro-mechanical or something? :hmm: Sounds like a Friday car...
 

·
Registered
2005 SRX AWD V8
Joined
·
204 Posts
Sure they did,
reminds me of my problem (intermittent loss of engine power during driving)

Took them 4 times to bring the engineers out. I do have to credit them tho, after they took apart the front differential to get at the cam shaft and other scenarios, they dropped the fuel tank, replaced the pump and lines, and also replaced the master ECM.

Fixed the problems, but I am sure it cost a BUTT load.
 

·
Registered
2007 SRX V6 AWD
Joined
·
15 Posts
Discussion Starter #10
What the hell does a 2A fuse have to do with pulling the key out of the ignition? Is the interlock electro-mechanical or something? :hmm: Sounds like a Friday car...
It's a good question, I don't know. The car, remember, also will not restart. So beyond the whole key not coming out of the ignition, the bigger issue was the car not restarting.
 

·
Registered
2007 SRX V6 AWD
Joined
·
15 Posts
Discussion Starter #11
Sure they did,
reminds me of my problem (intermittent loss of engine power during driving)

Took them 4 times to bring the engineers out. I do have to credit them tho, after they took apart the front differential to get at the cam shaft and other scenarios, they dropped the fuel tank, replaced the pump and lines, and also replaced the master ECM.

Fixed the problems, but I am sure it cost a BUTT load.
I admit, I do not have high confidence this will fix the issue. Or how this wire is being what I assume shorted out from time to time blowing the fuse. We'll see. If this does not fix the problem, I will start pushing for a replacement.
 

·
Registered
04 SRX V8
Joined
·
88 Posts
Yes the key needs power to come out.
Had the same problem when my battery died, couldn't get the key out. Was wondering how they were going to tow it to the dealer. Turns out there is a little back tab next to the gearshift. Pop it off and push a lever to put the car in neutral for towing.
 

·
Registered
99 Eldo ETC 04 SRX V8 AWD 13 XTS
Joined
·
202 Posts
Sure they did,
reminds me of my problem (intermittent loss of engine power during driving)

Took them 4 times to bring the engineers out. I do have to credit them tho, after they took apart the front differential to get at the cam shaft and other scenarios, they dropped the fuel tank, replaced the pump and lines, and also replaced the master ECM.

Fixed the problems, but I am sure it cost a BUTT load.

I don't think it cost them anything they just charge it back to vender. outsoursing isn't beautifull !!!!!!!!!!!!:bsflag:
 

·
Registered
2007 SRX V6 AWD
Joined
·
15 Posts
Discussion Starter #14
Well, we got the car back last night. Have made a few small trips already without having a problem. I drove it for 10 minutes this morning for the first time and the car did not seem as strong and was making this whoosh type sound that seemed to be coming straight from under the steering wheel.

I don't remember this sound being there, because I remember the car being pretty quiet when I drove it in the past. The problem is, I've never driven it that much to know it's characteristics just yet. And in fact, I'm pretty sure if this sound was there, I wouldn't want the car, it's quite noticable. We'll be chatting with the dealer though again to make sure this isn't a problem.
 

·
Registered
04,06,10 SRX; 2011/14 CTS Wagon
Joined
·
1,803 Posts
Eric, Eric, Eric...................what am I gunna do with you......................
 

·
Registered
Joined
·
858 Posts
Well, we got the car back last night. Have made a few small trips already without having a problem. I drove it for 10 minutes this morning for the first time and the car did not seem as strong and was making this whoosh type sound that seemed to be coming straight from under the steering wheel.

I don't remember this sound being there, because I remember the car being pretty quiet when I drove it in the past. The problem is, I've never driven it that much to know it's characteristics just yet. And in fact, I'm pretty sure if this sound was there, I wouldn't want the car, it's quite noticeable. We'll be chatting with the dealer though again to make sure this isn't a problem.
Eric - If it's the same sound my 04 made as the wheel was turned (like corduroy pant legs rubbing together as you walk) it's a problem. After the dealer on two or three occasions heavily lubed the steering shaft contact points through the firewall, etc. Cadillac Techinical directed the rack and pinion be replaced.
Again, if it's the same as mine it's the rack and pinion seal at the input shaft of the rack. Seal squeak travels up the steering column and the sound comes from the center hub of the steering wheel, like from under the air bag. Requires R&P replacement. Afterward mine felt loosey/goosey like a 50's Chrysler coaxial ps....little road feel....like the front end was on jack stands (with the engine running for power assist) while turning the wheels.
If it's as I suspect and you get rack and pinion replaced BE SURE it gets an alignment afterward and you get the "before/after" alignment machine printout... mine didn't and tire wear is murder in just a few hundred miles.
Keep us posted...
 

·
Registered
2007 SRX V6 AWD
Joined
·
15 Posts
Discussion Starter #17
Eric - If it's the same sound my 04 made as the wheel was turned (like corduroy pant legs rubbing together as you walk) it's a problem. After the dealer on two or three occasions heavily lubed the steering shaft contact points through the firewall, etc. Cadillac Techinical directed the rack and pinion be replaced.
Again, if it's the same as mine it's the rack and pinion seal at the input shaft of the rack. Seal squeak travels up the steering column and the sound comes from the center hub of the steering wheel, like from under the air bag. Requires R&P replacement. Afterward mine felt loosey/goosey like a 50's Chrysler coaxial ps....little road feel....like the front end was on jack stands (with the engine running for power assist) while turning the wheels.
If it's as I suspect and you get rack and pinion replaced BE SURE it gets an alignment afterward and you get the "before/after" alignment machine printout... mine didn't and tire wear is murder in just a few hundred miles.
Keep us posted...
Thanks John. My gf does not seem to think there is a problem. So I'm going to take a ride with her tomorrow to go over what I'm hearing. And WHEN it goes back to the dealer, I'll be letting them know the problem. Thanks, John.

And Jim, I'm not sure, help my Caddy!!! :) It will all work out, I still like the SRX, I just don't like ours! ;)
 

·
Registered
2005 SRX AWD V8
Joined
·
204 Posts
too bad you were not in california.

They just instituted a 30 day rule, where you can return any and all vehicles within 30 days.
 

·
Registered
2010 Perf 3.0,AWD, 2011 Yukon Denali,(403HP), had 04 SRX
Joined
·
1,160 Posts
too bad you were not in california.

They just instituted a 30 day rule, where you can return any and all vehicles within 30 days.

IF IT'S LIKE THE CHRYSLER..."WE'LL BUY IT BACK WITHIN 30 DAYS." offer......beware. Chrysler is allowed to charge a 3% restocking fee on the original MSRP, plus....$ .45 a mile!! OUCH!!
Few thousand, easy!!
 

·
Registered
2005 SRX AWD V8
Joined
·
204 Posts
honestly, I knew about the mileage charge, but the restocking fee is ridiculous, and I would get the lawyers on it.

But in the end, I ended up paying around 38k for a 4 yr lease, and if I started having weird problems they couldn't seem to solve within 12 days after recieving the car, paying a thousand bucks to say "thanks but no thanks" would be more than reasonable.

And then I am sure you would be getting into bargaining the car down to a lower price/lease term because now you have a "used" car with an unfavorable carfax report. They would be begging you to reconsider

(in my wildest dreams perhaps)
 
1 - 20 of 27 Posts
Top