Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
'97 STS
Joined
·
4 Posts
Discussion Starter #1
He all
I have a '97 STS and need to reprogram the key fob. I followed these instructions.

"1. With the ignition in the "RUN" position (engine does not necessarily need to be running, but it will work either way).
2. Press OFF and WARMER (or the OFF and PASSENGER WARMER buttons) on climate control panel simultaneously. Instrument Panel Cluster (IPC) will light all telltales, then go blank. System is now in DIAGNOSTIC MODE. After diagnostic mode cycles through and stops, press FAN DOWN button until "RFA?" is displayed, then press FAN UP. If "RFA DATA?" is displayed, press FAN DOWN. If "RFA OVERRIDE?" is displayed press FAN UP button.
3. If "RFA S00 NO OVERRIDE" is displayed, press FAN DOWN. If "RFA S01 PROGRAM FOB #1" is displayed, press FAN UP button.
4. IPC will show "0" on right side of Drivers Information Center (DIC) display. Press WARMER button on the climate control unit until "99" is displayed.
5. Press and hold TRUNK button on the transmitter. While holding TRUNK button, press LOCK button and hold both buttons for a total of 3 seconds. Locks will cycle when programming is complete. If transmitter is not programmed within 30 seconds after entering "99" on the display, system will default and you must begin at step #2 again.
6. To program second transmitter, press FAN DOWN button until "RF S02 PROGRAM FOB #2" is displayed, then press FAN UP. Repeat step #4.
7. To exit system, press AUTO, MODE UP, MODE DOWN, or RESET button."


The problem is when I get to step 2. i get a message of "RFA NO DATA" and it won't let me do anything execpt exit. Any help would be great and thanks.
 

·
Registered
'97 STS
Joined
·
4 Posts
Discussion Starter #2
I forgot to say that it just stopped working one day so i changed the battery and now it won't work.
 

·
Registered
1997 Cadillac STS (BOSE w/AUX In, Massage Seats, URPAS, "Z")
Joined
·
6,405 Posts
HOLD ON!!!
You get RFA No DATA?

This means the RFA module is NOT found on the data bus.
So you can try to program something that does NOT exists.
Start by diagnosing why is the RFA module dead.
This is the reason your remote stopped working, there is nobody to listen to it, the RFA will not loose the remote codes just by removing the battery.

I suggest to check the fuses, check the connections to the RFA (4 wires, 2 data PPL and 2 for power).
Any aftermarket stereo by any chance?
 

·
Registered
'97 STS
Joined
·
4 Posts
Discussion Starter #5
That’s sort of what I was thinking. Something became disconnected.
I checked the fuses and all are OK. Could you tell me where the RFA module is located?
No aftermarket stereo, factory Bose.
 

·
Registered
1997 Seville STS, 2000 Seville STS
Joined
·
1,694 Posts
Its in the trunk, on the passenger rear corner side, behind the CD changer under the felt liner.
 

·
Registered
'97 STS
Joined
·
4 Posts
Discussion Starter #7
Thanks.
I just went out to check and there is a 15 pin connector put nothing to connect it to. Guess i will have to pull the trunk apart.
 

·
Registered
1997 Seville STS, 2000 Seville STS
Joined
·
1,694 Posts
Sorry thats where it is in my 2000. The RFA is onthe left side of the electronics board at the front end of the trunk.
 
1 - 8 of 8 Posts
Top