Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
93 cadillac sts seville
Joined
·
44 Posts
Discussion Starter #1
hi guys i keep blowing my left tail light fuse on my 93 sts. i keep losing the dash and instrument lights at the same time. the new fuse is fine till i take the car out of park,into reverse then boom there goes another fuse.and no more dash lights or left tail lamp. i have already replaced all left bulbs and sockets, as well as both sides reverse bulbs and sockets .what to do? thanks in advance for all input.help!
 

·
Registered
'86 Brougham
Joined
·
54 Posts
Might want to check the grounds in that circuit. Helps if you have a wiring diagram and basically trace backwards.
 

·
Registered
93 cadillac sts seville
Joined
·
44 Posts
Discussion Starter #3 (Edited)
thanks i'll check the grounds in trunk first. i noticed a grey wire that has been disconnected in the gear shifter cig lighter area due to an aftermarket alarm which was installed by the previous owner. also there is a black wire disconnected in the same area. the grey wire is now routed into the aftermarket alarms harness. i noticed this when i removed the aftermarket stereo that had been sloppily installed by the previous owner. i returned the decks harness to stock. what are these black and grey wires for? could they be causing left tail fuse to blow once car put in reverse?
 

·
Registered
'02 ETC CE, '04 CTS-V, '04 XLR, '13 XTS Platinum
Joined
·
2,524 Posts
Look for a short in the reverse lighting circuit, since activation of that circuit seems to be blowing your fuse. The advice to start with a schematic is an excellent way to start. Look for a ground on the fused side of the circuit whenever your back up lights are energized (shifting into park --which energizes them briefly and of course, reverse.) You'll need a multimeter or lighted circuit tester to accomplish this.
CC
 
1 - 4 of 4 Posts
Top