Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
2003 cts
Joined
·
11 Posts
Discussion Starter · #1 ·
So this is my first post on this site my 03 cts wouldnt start saturday so i came on here and did some poking around and found the problem right away it was the crank position sensor and i just got her back today and thank god i knew what it was thanks to you guys because i saved alot of time and money, i had feeling they had no clue what to do so thanks
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,867 Posts
Hey your so welcome. I've seen a lot of members come on here saying the same thing. I will never forget this one member where his dealer replaced this and that, and back to this. Spent hundreds of dollars, under warranty. And the member came on here, searched around and everything pointed the the crank shaft sensor. He told the dealer, but they just laughed. Replaced it anyways, just to prove us wrong I guess, and what do you know. He's never been back, cus his car ended up being fixed. A simple $50 fix is all it takes at times.

KOT
 

·
Registered
03 CTS 3.2L (Sold) / 09 CBR 600rr /2014 GMC Sierra
Joined
·
7,872 Posts
great site, and very helpful people on here
 

·
Registered
'07 CTS black on black 3.6 FE5 'Nadine'
Joined
·
163 Posts
These guys spotted the failure of my LSD right away from my description . :yup:











No, not that 'LSD'
 
1 - 4 of 4 Posts
Top