Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
1994 Concours
Joined
·
8 Posts
Discussion Starter #1
Hello everyone, I just purchased my first Cadillac, a 94 Deville Concours with 206,000 miles on it currenlty. It has a bad transmission so I thought, but through research I discovered that it apparently has a bad solenoid.

I would drive fine for about 5 miles then lock itself in second gear and not shift again until after I shut the engine off and restart it. So I checked the codes and found on this forum that it was the shift solenoids.

I went to the junkyard and took the complete valve body out of another transmission and put it in mine. However now it goes into gear and slips badly when you try to take off in the forward or reverse. Could the valve body I got be bad, or did I put something together wrong.

I was thinking of trying another valve body as it didn't slip before I did this.

Anybody ever have this problem?
 

·
Registered
1995 SEDAN DEVILLE-4.9 & 1978 SEDAN DEVILLE-425
Joined
·
1,673 Posts
Congrats on your purchase! If i may ask---what did you pay for your 1994 Concours?
Only reason i ask is if it has the "original" tranny in it,you may be putting some $$$ into it with that many miles on it.You may have gotten a bad valve body,as you said.
 

·
Registered
1994 Concours
Joined
·
8 Posts
Discussion Starter #4
Congrats on your purchase! If i may ask---what did you pay for your 1994 Concours?
Only reason i ask is if it has the "original" tranny in it,you may be putting some $$$ into it with that many miles on it.You may have gotten a bad valve body,as you said.

Thanks - its an awesome car and its in great shape. I dont' mind you asking at all - I paid 500 for it at an estate auction. I bought the car knowing it had a transmission problem. Hoping that I just picked up a bad valve body. It wasn't slipping at all with the other one in there, it would actually drive great for a while, then suddenly lock in second gear and the engine light would be on till I shut the car off and restarted.

I'll post some pic's later .
 

·
Registered
1990 350 Brougham (The cruiser), 1988 Mark VII LSC (The DD)
Joined
·
5,545 Posts
Congrats on the car and I hope it lasts you a long time. I bought my Fleetwood for $300 with 66K miles, also knowing it had a bad trans. I paid $1495 to have it rebuilt and now it runs pretty well. I have a lot of work to do on it this summer like brakes and wheel bearings, but for a total of about $2250 it is a great car.
 

·
Registered
1994 Concours
Joined
·
8 Posts
Discussion Starter #6
I am going to the junkyard this weekend and will get another valve body I guess. What will happen if I put the old one back together with the shift solenoids from the new one without the checkballs installed?

I don't know where they go, and the flew out when I pulled it apart.
 
1 - 6 of 6 Posts
Top