Cadillac Owners Forum banner

1 - 2 of 2 Posts

·
Registered
2006 DTS Black Raven
Joined
·
162 Posts
Discussion Starter #1
This being my 3rd Caddy I would think I would know what to expect by now, but it seems that as I read some of the threads I get more nervous and I start to look out for more issues.

On my 98 I didn't have any problems til the 3rd year I owned it. Air pump burned out for my suspension, had to replace 1 of the third brake lights, the right rear courtesy lights, water pump went out and had to push my car to Firestone (got lucky that day cause they were bout to close), a dome light, the brakes (of course), and the right turn signal. Basic wear and tear. To be expected of course. Then in 06 I blew a head. Went ahead and traded up to an 01.

Had my 01 til Oct, 08 (RIP). My 01 for the 2 years I had it. Had a bad window washer pump. Fixed that. Had 2 window regulators on the same window go out. Fixed that. Sunroof clogged up and leaked in the car. Was gonna fix that til she got decommissioned. Other than that she was a tank. No other problems except that I did have a vacuum leak somewhere but again that happened right before she was murdered. So then after Verizon wrecked my baby I went and bout my 06. Drove 2 hrs to Mathews Va to the Chevy dealership after finding her on autotrader to get her. She was my 2nd pick cause the 1st that had the Navi that I wanted plus all Black etc etc got sold right when I called them.

8 months now that I've had her and now I have problems. I was hoping to atleast have a yr before anything pops off. Currently I am having the headlight flicker issue which currently I can't afford to get due to the brake job that I'm performing which unfortunately has been postponed since the company that I ordered my rotors from is having economic issues:hmm::rant2::mad:. See how I feel about that right now. Anyways waiting on a refund so I can go through someone else. Back to the lights. Since I'm having 1 go out I'm going to replace both. Well after I got off work last night I went home as I had planned on driving to Virginia Beach to spend my off time I always check my lights before I get on the road. Every single one. Now the pass side fog light is out along with the parking lamp. Atleast the hid stays on. Also the third brake light which I have been planning to replacing for sometime now.

I feel cursed for some reason. Ever since I moved to Northern Va I've had problems with my car. Bad juju. My right rear tire caught a nail. Had to replace. The right pass tire had a blow out on Route 1 on my way to work. That was fun. I'm just waiting on another tire to go. These were new tires from the dealership when I got the car. Oh I don't even know if this is a big deal but a few months back I was coming from Norfolk back to Dumfries. I left while the sun was up and when I hit I-295 the sun was beginning to set. Well I'm noticing that the interior of my car was pretty well lit. Come to find out the lights on the bottom of both the driver side and pass side were still on. Ok I'm thinking maybe I didn't close a door so I pull over to the side and check the doors. All shut. Hmmm. Besides its only just the front so I'm thinking that if it's just the front then it can't be a door problem. So I'm sitting there playing with the knob for the lights and they still won't cut off. So I finally cut my car off as a last hope and waited for a min and then started her back up. Problem solved and now I'm back on the road. I've had other instances where the windows wouldn't roll back up until I did the key thing or the driver side and pass side doors wouldnt lock while I was driving.

Is this just a problem with my car or is anyone else having issues like this.
Oh I forgot to mention the phantom dead battery I had too.:hmm: Went and got it tested and Autozone and it was fine.
 

·
Registered
2011 DTS Platinum
Joined
·
4,633 Posts
Southern Country,

Sorry to hear of all your troubles.
I have had a little trouble with mine also, but I was lucky and it was all fixed under warranty.

How many miles do you have on it?
I assume that it is over 50,000.
I have 61,500 on mine now so the factory warranty is no longer valid.

I do have a slightly warped rotor on the front. The weird thing is...sometimes you can feel it when you are on the brakes, and sometimes you can't. :)

Took it in just before the warranty was out...me and the tech took it out for a drive...it was just as smooth as it could be. No vibration at all. Just my luck. :) They inspected the brakes and said I had about 40 to 50% of pad life left...at that time.

I have not had much tire trouble...other than them being real noisy and rough riding, but from what I can find out...that is "NORMAL" for this type of tire. Bridgestone Turenza 245x50x18.

About the dead battery...If mine sets for more than about five days...the battery will go down.
First time it happened...Roadside Service came out and replaced the battery.

I finally found what I "THINK" was the problem. I have a cell phone charger and radar detector plugged in and never unplug them when the car is sitting. Over time... (several days)...they drain the battery.

Had a problem with the AC seat not blowing air from the back of the seat. Bottom was cool...but no air from the seat back. An air duct had come loose.
One of the front parking sensors had to be replaced.
The third brake light had real tiny, hairline cracks in it and was replaced.
The drivers door module was replaced at another dealer visit. Don't remember exactly why right now. :)

Yesterday, the SERVICE TIRE MONITOR message came on..the drivers front tire was not showing any pressure. The other three were OK.
Later "ALL" of theml were working ok...don't know what the problem was but it will probably come back.

I bought a 1980 Sedan deVille...new in 1980.
Drove it till 2001. Had almost 250,000 miles on it when I sold it.
That was, without a doubt...the BEST CAR I have ever owned in my life.
Except for changing the oil, I did almost NOTHING to that car except put gas in it and drive it.
Never did anything at all to the engine or transmission.
Only put plugs in it one time, at about 150,000 miles.
It still had the original plug wires on it. :)
I only remember putting brakes on it one time.
It just never broke down on me... at all.

Can't say that about this one.
It has never actually BROKE DOWN and left me stranded, or anything like that, but it has been in the shop for various things, more than the last half a dozen cars I have owned... all put together. :)
But the strange thing is ... I still, REALLY REALLY like this car, even after all of the trouble I have had with it. :)

I figure I will keep it another year and a half, *depending on how much trouble I have with it).. till the 2012's come out, and trade it for a low mileage CPO 2011.
It will probably have 125,000 miles on it by then.
My GMPP warranty is good till 104,000 miles. :)

Texas Jim
 
1 - 2 of 2 Posts
Top