Cadillac Owners Forum banner

1 - 10 of 10 Posts
7

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I first will like to say hello to everyone, and I am happy to be here.
I have a 76 Seville and I don't known much about them, I brought it because I always like them, and this one appears to be in good shape except it doesn't run. The previous owner said that it did until he took the cadilac convertor off and put new muffler with a new tail pipe. I can't get it to start, it will run on for about 2 seconds then just die out. I took a reading of the gas presure and it was around 40 psi. Any help would be appreciated.
 

·
Registered
85 Eldo Biarritz
Joined
·
808 Posts
Well, you've found your problem. No Cadillac will ever run without a cadilac convertor attached...

I'm just joking - coudln't resist the pun. :D

Sorry, I don't know about 76 Seville. But I'm sure others will chime in.

Welcome!
Peteski
 

·
Registered
2008 SRX-V8, 1991 Eldorado
Joined
·
1,543 Posts
Welcome to the forum....

76 Seville should have a fuel injected Oldsmobile 350 engine if I am not mistaken, then again, If I am, I will get flamed to the ground....LOL

Obviously I am not at all familiar with the 76 Seville, but there should be several who are. Anyway... be patient, there are many good folk here.
 

·
Banned
1995 ETC, 75 Deville, Cad500 powered 73 Apollo, 94 Mark VIII
Joined
·
7,971 Posts
You're right on the Olds FI 350. But that's about as far as my knowlege of the early Sevilles goes. If you can find one, pick up a factory service manual or at least a Helm/Chiltons - they kinda suck but they help.
 
7

·
Guest
Joined
·
0 Posts
Discussion Starter #5
peteski said:
Well, you've found your problem. No Cadillac will ever run without a cadilac convertor attached...

I'm just joking - coudln't resist the pun. :D

Sorry, I don't know about 76 Seville. But I'm sure others will chime in.

Welcome!
Peteski
You did get my attenion;:worship: Hi to all.
 

·
Registered
1994 Sedan Deville
Joined
·
2,146 Posts
:welcome: to the Forums. Glad to have you here. You have already checked the fuel pump, alternator, and injectors right?? I'm not really sure on any other things to check but the "experts" will come to the rescue shortly.
 
7

·
Guest
Joined
·
0 Posts
Discussion Starter #7
addison_ii said:
:welcome: to the Forums. Glad to have you here. You have already checked the fuel pump, alternator, and injectors right?? I'm not really sure on any other things to check but the "experts" will come to the rescue shortly.
First thanks for the welcome, Ok how do you check the injectors? :hide:
 

·
Registered
1994 Sedan Deville
Joined
·
2,146 Posts
76ville said:
First thanks for the welcome, Ok how do you check the injectors? :hide:
No need to hide :D I don't know how either but I'm guessing that whatever part is covering them has to be taken off to see if they are spraying the fuel where it needs to be for the car to keep running. I will try to find info for you.
 
7

·
Guest
Joined
·
0 Posts
Discussion Starter #9
Hey everyone,
Check and found out that the injectors were not getting power. So we check futher and began to think it was the ECU. But first trace power to speed control. Ohm the speed control and only one of the magnatic switches were working. Went to salvage yard pull distributor out of a 76 seville and remove the speed control. For $7.50 brought the part, install it on my distributor and reinstall it. After a few trys the engine fire up. I felt real good. Set the timing and went for a cruise.
Thanks for the direction everyone.
 

·
Registered
1994 Sedan Deville
Joined
·
2,146 Posts
good deal 76ville.(hey that rhymed). Post some pics when you get a chance.
 
1 - 10 of 10 Posts
Top