Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
2005 CTS
Joined
·
1 Posts
Discussion Starter #1
I just joined and this is my 1st post on this sight. Thanks for having me. My 2005 CTS has developed a random stutter,. I feel it at stop lights and slow moving traffic. Its totally stock with 150K miles 4.6 engine. Seems to run well at cruising speeds but what perplexes me is there is no real pattern of this jerking and stuttering. Fuel filter? Maybe?
Thanks for any ideas.
 

·
Registered
2003 CTS
Joined
·
25 Posts
I would just like to add that I also have this. Never any code. Happens parked, in gear, or a lower speeds in gear. If it DOES happen at freeway speed, it is not noticeable.
 

·
Registered
2005 CTS/ 2008 DTS/ 2008 STS V8 N*/ 2011 CTS4 ALL W/D Pearl
Joined
·
688 Posts
I just joined and this is my 1st post on this sight. Thanks for having me. My 2005 CTS has developed a random stutter,. I feel it at stop lights and slow moving traffic. Its totally stock with 150K miles 4.6 engine. Seems to run well at cruising speeds but what perplexes me is there is no real pattern of this jerking and stuttering. Fuel filter? Maybe?
Thanks for any ideas.
You mean a 3.6 not a 4.6 which would be the Northstar.

Make sure the oil is FULL.
 

·
Registered
07 CTS
Joined
·
1 Posts
I had this exact same problem in my 07 CTS 3.6L. It was caused by a faulty ignition coil.

If you take it in, they'll think you're crazy since it doesn't throw a code.

If you do nothing, eventually the problem will progress to the point that you'll have random 30 second periods of the CEL flashing and the car refusing to accelerate. That'll get more and more frequent. Once the CEL comes on you can get a code and know which coil.

I'd recommend replacing all of them, though. I've had two go out so far and I can feel that a third is on its way now.
 
1 - 8 of 8 Posts
Top