Cadillac Owners Forum banner
1 - 5 of 5 Posts

·
2006 STS AWD
Joined
·
4 Posts
Discussion Starter · #1 ·
This is my first time on this forum and I don’t know if so was supposed to post this here, but I am currently having trouble with my intellibeam as said in the title. When it’s sunny and I have the setting set to auto, the lights would just turn on. After taking a left, the high beams would just turn on. At night, they would turn on even when lots of other cars are coming from the opposite side of the road or are in front of me. I can turn them off when I just push the stalk a little, but then they always turn back on and I feel like I’m blinding other drivers around me. I turn off the rear view mirror to “turn off the system” but they always turn on. I don’t know if the headlight sensor needs to be replaced or the small camera in the mirror need to be replaced, but does anyone know what is wrong with my car? I should mention I drive the ‘06 STS AWD and this always happens when I have the setting on “Auto” or when it’s on the normal headlight option and I’m so sorry this is so long. I am going to stop typing this right now.
596986
This is also how my mirror looks.
 

·
Registered
Joined
·
5 Posts
I had the same problem in my 08 STS AWD.....There’s a 15amp fuse under the hood for the intellabeam system! Pull that fuse and it’ll stop....you can still use your brights at the switch. Hope this helps??!!
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top