Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Instrumenten Panel Cluster

To my 94 Cadillac de Ville the instrument reading remains dark. The safety devices are examined, all into all functions go o.k. , evenly only no announcement.
 

·
Registered
1968 Cadillac Sedan deVille, 1994 Chevrolet G20
Joined
·
2,795 Posts
Check your fuses. A bad fuse will keep the panels from working. Check your dimmer switch for your interior lights too, that could be a factor.
 

·
Registered
Cadillac
Joined
·
6 Posts
Re: Instrument Panel Cluster/digital display

1993 Fleetwood Brougham

I've a problem like this. The Digital speed/fuel display is completely out! I get all the side signals when the key is first turned on but no speed.

I have checked all the fuses and the single 5 amp one under the steering. I have checked all the lights and dimmers but to na avail.

The readings I get from the diagnostics point to 144 on the CCM, and 30,33,35,37 on the ABS/TC system. Could it be the main brain??:suspect:

Thanks for any pointers.
 

·
Registered
'94, '93 & '76 FWBs. '77 '79 & '73 CDVs, '65 Drop, '62 CDV
Joined
·
414 Posts
Re: Instrument Panel Cluster/digital display

1993 Fleetwood Brougham

I've a problem like this. The Digital speed/fuel display is completely out! I get all the side signals when the key is first turned on but no speed.

I have checked all the fuses and the single 5 amp one under the steering. I have checked all the lights and dimmers but to na avail.

The readings I get from the diagnostics point to 144 on the CCM, and 30,33,35,37 on the ABS/TC system. Could it be the main brain??:suspect:

Thanks for any pointers.
HI Zugy, Did you get this fixed and what was it? I've exactly the same thing on my 93 FWB
Thanks Nick
 
1 - 4 of 4 Posts
Top