Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter #1 (Edited)
jumped in my 94 deville today and had a wicked whine from teh steering pump. it has whined alittle since i bought it over 3 years ago, but this was a very bad whine. I popped the cap off of the pump and it was bone dry.

i added fluid, and it was back to normal. i get to work, park the car noticed a nice leak of fluid near the front drivers tire. So i looked on alldata and it says its either an inner rack seal, or teh pinion shaft seal is shot.

how bad of a job is this? the weather is supposed to be alittle nicer, so i plan on doing this over the weekend. i may aswell replace the pump too, sickntired of the whine.

thanks for the help!

matt
 

·
Registered
'80 Fleetwood Coupe, 1994 and 1995 Mercedes 140 Coupe
Joined
·
2,096 Posts
Best way out is to replace the rack with an exchange unit. Not really a shade tree job. You need a set of line wrenches and the toe needs to be checked afterward.
 

·
Registered
Joined
·
137 Posts
Discussion Starter #3 (Edited)
Today, i looked at it. It turns out to be a line from the rack to the pump cooler. its just a little friggin pin hole in the hard line. its a metal/rubber line. it looks like it would be a bitch to replace! it goes from the rack, along the frame rail, to the pump cooler.
 

·
Registered
Joined
·
137 Posts
Discussion Starter #6
since its only a hose for the cooler, couldnt i replace the bad section with a piece of rubber hose? i thought about this last night while laying in bed.


or is this idea stupid?
 
1 - 6 of 6 Posts
Top