Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I just put a Idle Speed Control motor in my 93 Deville and now it seems the timing is off........It is idled up very high for some reason and its not braking like it use to.......I read something about a minimum idle speed adjustment but that seems a little too much for me seeing that I don't have the knowlege or a tachometer...........Does anyone know anything else I can do to adjust the idle now that I have installed a new Idle Speed Control(ISC)? Will this lead to some form of damage if I don't correctthis really soon?
 

·
Registered
Joined
·
20 Posts
as long as you didn't touch the minimum idle control screw...it should be fine

1 - go into PCM diagnositics 5.3(override) with the car running...once you get into 5.3...hit the cooler button...this will retract the ISC plunger..make sure the throttle lever is resting on the min. idle screw...if not you need to adjust the ISC...if it is..exit diagnostics mode and let the ecm relearn idle

relearn idle - remove fuse # 6 from the inside fuse box for 10 seconds then replace, let car idle for 10 minutes, then let car idle in Drive for 3 minutes with the AC off, then 3 minutes with the AC on

if you need more info on the ISC override procedure or ISC plunger adjustment......let me know

-chris
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
I had to screw in the Minimum Idle Speed Screw when I brought the motor so i did in fact touch it
 
1 - 4 of 4 Posts
Top