Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
1994 Sedan DeVille,and a 1984 ElDorado
Joined
·
9 Posts
Discussion Starter #1
I Know u guys get this on a regular basis,so if i am repeating what someone else has written,please excuse me, but these dang codes are driving me crazy!!!:mad:
I keep pulling:
I041(history): Batt voltage too low?
R061(current):SIR indicator curcuit failure?
R062(current):redundant SIR indicator failure?
then it will say low battery voltage, then, check airbag controls, then,it tells me i need to change my oil?oh an also my gas gauge will flash empty, and the range gauge shows LOW, then all of a sudden I'll be driving down the road and I'll notice that my gas gauge says 15-gal, and the range has changed to275??? WTF is gong on here???:rant2: oh and it surges at idle also!
Can Somone PLEASE help me?????????
 

·
Registered
99 Seville STS, 08 STS4 N* 1SG F55
Joined
·
3,516 Posts
Step 1: Tell us what year/model car and mileage
Step 2: Check your battery, battery connections and alternator performance. At first guess it sounds like you have a low voltage problem that is driving the elecronics crazy and resulting in most, if not all of the bad behavior you describe.
 

·
Registered
1994 Sedan DeVille,and a 1984 ElDorado
Joined
·
9 Posts
Discussion Starter #3
I'm Sorry Guys ,Yeah that would help wouldn't it? DUH! I Is a 1994 Sedan DeVille, 4.9L, Automatic, it has 95,768-miles on it, It runs and drives really good,it's just not as good as it should be!
 

·
Registered
1994 Sedan DeVille,and a 1984 ElDorado
Joined
·
9 Posts
Discussion Starter #4
Something new has popped up!!! It is now showing a I039: loss of road sensing suspension data?, also on my dash it is saying service air bag system and service ride control, and my anti-lock brake light is on,and my airbag light is on?? Starting to get worried here!!!!
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,990 Posts
Follow Chubby's advice. These cars will get very weird when battery voltage is low.
 

·
Registered
1994 Sedan DeVille,and a 1984 ElDorado
Joined
·
9 Posts
Discussion Starter #6
Thanks guys I had a bad positive battery wire,replaced it and it fixed everything but engine surge,and the ride control,:thumbsup:
Thank you for all the help!ttyl,.:D
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,990 Posts
Rod out the EGR tubes in the TB. That might help your engine surge. If not, check for a vacuum leak or bad ISC motor.
 

·
Registered
99 Seville STS, 08 STS4 N* 1SG F55
Joined
·
3,516 Posts
The I039 code is probably tripping the service ride control warning. May have been caused by the low voltage. Try clearing the codes and see if it is still present.
 
1 - 8 of 8 Posts
Top