Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
2011 SRX
Joined
·
2 Posts
Discussion Starter #1
I have been having a little problem with my hubcaps on my 2011 SRX. I don't know if I am doing something wrong, or if this is a problem with the wheels but I have replaced 3 hubcaps in the 2 years that I've owned the vehicle. They are all on the front of the car - 2 on the passenger side and 1 on the driver. Is anyone else having this problem? Is there a solution? I'm kind of tired of buying replacement hubcaps..
 

·
Registered
2014 SRX AWD LUX terra mocha/shale brownstone
Joined
·
163 Posts
If you have wheels similar to the Lux trim of my 2014, there is only 1 correct way to mount the hubcaps and 5 incorrect ways they can be mounted. I would guess that caps may be more susceptible to coming off if they are not properly mounted.

With the cap removed, you will notice on the inside of the cap there are 6 latching tabs and 1 locating tab. The locating tab is in the direction to the bottom of the Cadillac crest on the front face of the hub cap.

On the wheel you will notice there is a groove that will match to the locating tab. The other grooves on the wheel are simply to allow space for the lug nuts to clear the wheel.

To attach the hubcap to the wheel, simply line up the locating tab of the hubcap to the locating groove of the wheel and gently push the hubcap on the wheel.

By the way, I remove the hubcap from the wheel with a paint can opener tool. It fits perfectly in the pry cutout and does not scratch anything as a screwdriver or other tool might.

Good luck.
 

·
Registered
SRX
Joined
·
146 Posts
The best way is to look inside the cap there is a picture of a tire valve line that picture up with your tire valve then you should have no problem
 

·
Registered
14 SRX Luxury
Joined
·
613 Posts
You could install them with a bead of silicone sealer to help keep them on. I haven't had any trouble with mine though.
 
1 - 5 of 5 Posts
Top