Cadillac Owners Forum banner

1 - 12 of 12 Posts

·
Registered
2012 CTS, thunder grey chromaflair
Joined
·
120 Posts
Discussion Starter #1
2012 CTS. When I have the bluetooth connected to my phone, the instrument cluster shows my phone number. The navigation screen shows a single button: "Hang Up". Pressing the "Hang Up" button on the navigation screen or on the steering wheel only results in a voice confirming "hang up the phone". How do I return to Radio or any other audio functions? The "Audio" button doesn't do anything. My phone always has bluetooth on. It gets automatically connected to the car. And radio just stops. Help ... :confused:

Many thanks!
/dan
 

·
Registered
2009 CTS 3.6 LY7
Joined
·
285 Posts
Afraid I can't help directly, this stuff too complicated. But I can confirm BT works as expected (i.e. audio source automatically switches between phone and AM/FM/CD/Aux) in my '09 with iPhone6. Did you try pushing the phone button on the steering wheel, then does the car say "Ready"?
 

·
Registered
2012 CTS, thunder grey chromaflair
Joined
·
120 Posts
Discussion Starter #3
Afraid I can't help directly, this stuff too complicated. But I can confirm BT works as expected (i.e. audio source automatically switches between phone and AM/FM/CD/Aux) in my '09 with iPhone6. Did you try pushing the phone button on the steering wheel, then does the car say "Ready"?
Yes, the car did say "Ready". I didn't try dialing, and I have no reason to think it wouldn't work.

I imagine how it should work is,
1. bluetooth is connected;
2. Audio (Radio or XM or HDD) continues to function as normal;
3. a call comes in, ring, ring ...
4. hit a button to answer the call, then audio is muted;
5. when the call finishes, hang up the phone, audio continues ...

I just can't get the audio to do anything after the bluetooth connect :mad:
 

·
Registered
2010 Cadillac Premium AWD CTS
Joined
·
710 Posts
I have the same problem on my 2010 cts premium. After the call everything freezes. Sometimes if I hang up the call using the hang up button on the steering wheel it goes back to radio. But if I tap the hang up button on the radio itself it doesn't. It is hit or miss at best.
 

·
Registered
2009 CTS4 Premium & 2012 SRX4 Luxury
Joined
·
604 Posts
After I paired my Samsung Galaxy Stellar to my 09, I leave the Bluetooth turned on my phone all the time. When I get in the car and start it, I see "Bluetooth" message show up in the DIC. After a few seconds it goes away, and there is no further indication of the sync. I can place a call by holding the hands free button, then going through the "Hands Free", "Bluetooth", "Voice" prompts to place an outgoing call, or simply press the same button or press the answer call button on the display when there is an incoming call to answer. But otherwise my audio works normally and there is no indication of the Bluetooth sync.

Have you tried deleting the pairing and re-doing that? What is your phone model?
 

·
Registered
2011 CTS4 3.6
Joined
·
5 Posts
I have a 2011 CTS premium, and the same thing happens to me. Most of the time if I leave it alone it will unfreeze after the call and go back to the radio. I've had good luck pressing the down button on the steering wheel, it usually hangs up the call and goes back to the radio rather quickly.
 

·
Registered
2012 CTS, thunder grey chromaflair
Joined
·
120 Posts
Discussion Starter #7
After I paired my Samsung Galaxy Stellar to my 09, I leave the Bluetooth turned on my phone all the time. When I get in the car and start it, I see "Bluetooth" message show up in the DIC. After a few seconds it goes away, and there is no further indication of the sync. I can place a call by holding the hands free button, then going through the "Hands Free", "Bluetooth", "Voice" prompts to place an outgoing call, or simply press the same button or press the answer call button on the display when there is an incoming call to answer. But otherwise my audio works normally and there is no indication of the Bluetooth sync.

Have you tried deleting the pairing and re-doing that? What is your phone model?
I have a Samsung Note3. I will give it another try and see if deleting and re-pairing works or not. Thanks!
 

·
Registered
2009 CTS4 Premium & 2012 SRX4 Luxury
Joined
·
604 Posts
Being that is pretty new, another thing you might check is if there is a Bluetooth update available. I've read of some problems with certain phones and Bluetooth version incompatibility. If you have OnStar contact them and ask if you have the latest update. Supposedly you could also ask for a 30-day free trial to get connected, and then also get the free update. Google OnStar Bluetooth Update.
 

·
Registered
2012 CTS, thunder grey chromaflair
Joined
·
120 Posts
Discussion Starter #9
Being that is pretty new, another thing you might check is if there is a Bluetooth update available. I've read of some problems with certain phones and Bluetooth version incompatibility. If you have OnStar contact them and ask if you have the latest update. Supposedly you could also ask for a 30-day free trial to get connected, and then also get the free update. Google OnStar Bluetooth Update.
Before doing anything to fix the problem, I gave it another shot. Not sure what I did differently, but it seems to work the way I thought it should now. Thank you for the suggestions! Hope the problem won't come back.
 

·
Registered
2014 CTS Wagon
Joined
·
14 Posts
My 2014 Wagon freezes occasionally when I hang up the phone after a call. Did it with an Iphone 5 and Iphone 6. The screen will go back to XM or whatever I was listening to after a few minutes. It is irritating though!
 

·
Registered
2011 CTS
Joined
·
42 Posts
I had these problems until I updated to the latest iOS version on my iPhone 5S. There were a number of fixes included in one of the latest 8.1.x releases. I was very skeptical that it was an Apple issue but it seems the Bluetooth handshake process was improved and things are much better now. I do occasionally get double "call disconnected" messages but it doesn't lock up anymore.
 

·
Registered
2012 CTS, thunder grey chromaflair
Joined
·
120 Posts
Discussion Starter #12
Before doing anything to fix the problem, I gave it another shot. Not sure what I did differently, but it seems to work the way I thought it should now. Thank you for the suggestions! Hope the problem won't come back.
Well, my problem sort of comes and goes as it pleases. Sometimes it works perfectly, then, other times, as soon as the bluetooth gets connected, Radio gets cut off, pressing the hang up button multiple times, helps sometimes. Not sure if I just wait long enough it would do the same. But, whenever it happens, I get impatient and start presing both hang up buttons repeatedly ... Such a nuisance
 
1 - 12 of 12 Posts
Top