Cadillac Owners Forum banner

1 - 10 of 10 Posts

·
Registered
Cadillac
Joined
·
76 Posts
Discussion Starter #1
Hey there. i have an 02 and the SSS light came on and when i had the code checked it said steering position sensor. i can see the little bugger up there, but dont know how to change it. Does anyone have any input on this so i can get that dash light off..
thanks
 

·
Registered
Cadillac
Joined
·
76 Posts
Discussion Starter #3
Thanks for the reply!
Sounds like the same procedure. looking at the part, i saw the bolt that you suggested clocking the wheel 90* to get off, and saw the grey retaining clip that i would then remove. So the next step, does the white ring just slide forward and off the shaft? and the new one just slides on? thanks again.
 

·
Registered
'02 Escalade
Joined
·
200 Posts
does the white ring just slide forward and off the shaft? and the new one just slides on?
Yup, that's all there is to it. If you need to buy the part, order one from www.gmotors.com. That's a dealership in FL that sells OEM parts at a discount. My local stealership wanted $90 for the part...I got it shipped to my door for ~$60 from gmotors.com.
 

·
Registered
Cadillac
Joined
·
76 Posts
Discussion Starter #5
thanks for all the great help and the link. sounds like an easy fix. thanks again
 

·
Registered
Cadillac
Joined
·
76 Posts
Discussion Starter #7
just replaced it. fairly easy job. only thing i am wondering, is the new unit had a black "pin" in it, keeping it from rotating. and had a mark from the factory lining it up. what is the deal with this pin, and is there a certain way i should have lined it up. replaced it and cranked the car up and the light was still there. so maybe i need to disconect the battery for a while....
 

·
Registered
Cadillac
Joined
·
76 Posts
Discussion Starter #8 (Edited)
Just an update to help those who may search this in the future. when my SSS light came on i had it scanned and it said the steering position sensor. so i got a new one and replaced it. here is instructions posted by digitalcaddie. if you do this install, it helps to turn the wheel 90 degrees left to get the nut facing down so you can get it loose, then turn the wheel back to straight and remove the nut and bolt, then push the universal joint toward the firewall. Next use a flat screwdriver or something similar to take 2 of the 3 tabs loose on the grey retainer holding the steering wheel position sensor in place and then work the 3rd tab on the top loose. Slide and old sensor down and off and you're in business. now when you put the new one back on, take the pin out of the new one that keeps it from turning. and slide it on the steering shaft. it has a flat section so it can only go one of two ways. also make sure you dont turn the wheel or shaft or anything while its apart, keep it inline. then put it back together. then when i turned it on i still had the light. well apparently this light doesnt just turn off. back to the auto shop and they had to clear it. now everything is great. no more light.. ahhhhhh.. hope this helps someone.
 
NONE
Joined
·
13 Posts
NOT Sure If Anyone Will Read this, But I have the SSS Light on Service Stability System light on in my 2002 Escalade..

TO Everyone and Anyone who had this Issue Did You guys Also Have a Buzzing Noise or lsight bog down around 8-10 mph.. I get a Buzzing Noise along with the SSS Light coming on.. Once the Buzzing is over about 2-3 seconds.. The SSS Light comes on and Stays on Until I Turn the Truck off and Restart it.
Consistently Comes on EVERYTIME at 8-10Mph and stays on. Buzzing and bogging down for a second or two always happens..
Would this be the Wheel Position Sensor....?
Should I take it to the SHop?
I NEVER have worked on a Escalade or Chevy Truck dont know alot... DO NOT WANT TO MESS ANYTHING UP. But Then I dont want to spend Big $$ at dealer or Shop..
PLEASE ADVISE THANKS! :)
 

·
Registered
2003 ESV
Joined
·
326 Posts
I think it's your wheel sensor. When they break, the traction control keeps kicking in when you go to take off from a stop because the computer thinks you are loosing traction. Do you have a button to turn off your traction control? Try turning it off and see if the bogging stops. You will still get the lights/alarms, but, the bogging should stop. If yes, those are the symptoms I had. I replaced the bearing/sensor assembly and it solved the problem. If you can find someone with a nice CPU reader, (maybe the parts store), they can tell you which corner is the problem. Once the part is replaced, the code needs to be cleared as well with the CPU reader. It might go out eventually, but, I had to clear mine out a couple times before the lights stayed off (ABS light . TC light etc...). Hope that helps.

----------

The part is about 120 from a part store. Labor is probably 2 hours.
 
1 - 10 of 10 Posts
Top